]> git.pld-linux.org Git - packages/php-pecl-memcache.git/blob - php-pecl-memcache.spec
be1334990e8f82bc68548dd424b282310f922ec0
[packages/php-pecl-memcache.git] / php-pecl-memcache.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         php_name        php%{?php_suffix}
6 %define         modname memcache
7 %define         php_min_version 5.0.0
8 %include        /usr/lib/rpm/macros.php
9 Summary:        %{modname} - a memcached extension
10 Summary(pl.UTF-8):      %{modname} - rozszerzenie memcached
11 Name:           %{php_name}-pecl-%{modname}
12 Version:        3.0.9
13 Release:        1
14 License:        PHP 3.01
15 Group:          Development/Languages/PHP
16 #Source0:       http://pecl.php.net/get/%{modname}-%{version}.tgz
17 Source0:        https://github.com/websupport-sk/pecl-memcache/archive/NON_BLOCKING_IO_php7.tar.gz
18 # Source0-md5:  7751d8191302a726449d7c6506b8783d
19 Source1:        %{modname}.ini
20 Source2:        %{modname}-apache.conf
21 Source3:        %{modname}-lighttpd.conf
22 Source4:        config.php
23 Patch0:         %{modname}-webapp.patch
24 Patch1:         tests.patch
25 URL:            http://pecl.php.net/package/memcache/
26 BuildRequires:  %{php_name}-devel >= 3:5.0.0
27 BuildRequires:  %{php_name}-xml
28 BuildRequires:  php-packagexml2cl
29 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
30 BuildRequires:  rpmbuild(macros) >= 1.650
31 %if %{with tests}
32 BuildRequires:  %{php_name}-cli
33 BuildRequires:  %{php_name}-pcre
34 BuildRequires:  %{php_name}-session
35 BuildRequires:  %{php_name}-spl
36 BuildRequires:  memcached
37 %endif
38 %{?requires_php_extension}
39 Requires:       %{php_name}-session
40 Requires:       %{php_name}-zlib
41 Suggests:       memcached
42 Provides:       php(memcache) = %{version}
43 Obsoletes:      php-pecl-memcache < 3.0.8-5
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %define         _webapps        /etc/webapps
47 %define         _webapp         %{modname}
48 %define         _sysconfdir     %{_webapps}/%{_webapp}
49 %define         _appdir         %{_datadir}/%{_webapp}
50
51 # bad depsolver
52 %define         _noautopear     pear
53
54 # put it together for rpmbuild
55 %define         _noautoreq      %{?_noautophp} %{?_noautopear}
56
57 %description
58 Memcached is a caching daemon designed especially for dynamic web
59 applications to decrease database load by storing objects in memory.
60
61 This extension allows you to work with memcached through handy OO and
62 procedural interfaces.
63
64 %description -l pl.UTF-8
65 Memcached to zaprojektowany dla dynamicznych aplikacji internetowych
66 daemon cachujący mający za zadanie zmniejszenie obciążenia bazy danych
67 przez przechowywanie w pamięci obiektów.
68
69 To rozszerzenie umożliwia pracę z memcached za pomocą poręcznego
70 zorientowanego obiektowo (oraz przez procedury) interfejsu.
71
72 %package web
73 Summary:        Web interface for memcache
74 Group:          Libraries
75 # does not require extension itself
76 Requires:       php(core) >= %{php_min_version}
77 Requires:       php(date)
78 Requires:       php(gd)
79 Requires:       php(pcre)
80 Requires:       webapps
81 Requires:       webserver(php) >= 5.0
82 %if "%{_rpmversion}" >= "5"
83 BuildArch:      noarch
84 %endif
85
86 %description web
87 Via this web interface script you can manage and view statistics of
88 memcache.
89
90 %prep
91 %setup -qc
92 mv pecl-%{modname}-*/{.??*,*} .
93 %patch0 -p1
94 %patch1 -p1
95
96 # locks up on carme, likely due udp very long timeout
97 rm tests/039.phpt
98 rm tests/041.phpt
99 rm tests/042.phpt
100
101 # skip failed tests
102 xfail() {
103         set +x
104         while read s; do
105                 t=$(echo "$s" | sed -rne 's/.+\[(.+)\]/\1/p')
106
107                 test -f "$t"
108                 echo >&2 "XFAIL: $s"
109                 cat >> $t <<-EOF
110
111                 --XFAIL--
112                 Skip
113                 EOF
114         done
115 }
116
117 xfail <<'EOF'
118 memcache->addServer() [tests/019.phpt]
119 memcache->set()/memcache->get() with multiple keys and load balancing [tests/020.phpt]
120 memcache->getExtendedStats() [tests/022.phpt]
121 memcache_get_extended_stats() [tests/022a.phpt]
122 memcache->delete() with load balancing [tests/023.phpt]
123 memcache->increment() with load balancing [tests/025.phpt]
124 memcache->delete() with load balancing [tests/026.phpt]
125 memcache->addServer() adding server in failed mode [tests/031.phpt]
126 memcache->getServerStatus(), memcache->setServerParams() [tests/032.phpt]
127 memcache::connect() with unix domain socket [tests/035.phpt]
128 memcache->get() over UDP [tests/038.phpt]
129 memcache->increment()/decrement() with multiple keys [tests/040.phpt]
130 ini_set('memcache.redundancy') [tests/043.phpt]
131 ini_set('memcache.session_redundancy') [tests/044.phpt]
132 hash strategies and functions [tests/046.phpt]
133 ini_set('session.save_handler') with unix domain socket [tests/053.phpt]
134 FLAKY: memcache->addServer() with microsecond timeout [tests/056.phpt]
135 ini_set('session.save_handler') [tests/036.phpt]
136 ini_set("memcache.allow_failover") [tests/029.phpt]
137 %if "%{php_major_version}.%{php_minor_version}" >= "7.1"
138 strange keys [tests/005.phpt]
139 %endif
140 EOF
141
142 %build
143 packagexml2cl package.xml > ChangeLog
144 phpize
145 %configure \
146         --with-zlib-dir=/usr
147 %{__make}
148
149 %if %{with tests}
150 # simple module load test
151 %{__php} -n -q \
152         -d extension_dir=modules \
153         -d extension=%{php_extensiondir}/pcre.so \
154         -d extension=%{php_extensiondir}/spl.so \
155         -d extension=%{php_extensiondir}/session.so \
156         -d extension=%{modname}.so \
157         -m > modules.log
158 grep %{modname} modules.log
159
160 cat <<'EOF' > run-tests.sh
161 #!/bin/sh
162 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
163 exec %{__make} test \
164         PHP_EXECUTABLE=%{__php} \
165         PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl session" \
166         RUN_TESTS_SETTINGS="-q $*"
167 EOF
168 chmod +x run-tests.sh
169
170 # Launch the Memcached service and stop it on exit
171 %{_sbindir}/memcached -p 11211 -U 11211 -d -P $PWD/memcached.pid
172 trap 'kill $(cat memcached.pid)' EXIT INT
173
174 ./run-tests.sh
175 %endif
176
177 %install
178 rm -rf $RPM_BUILD_ROOT
179 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
180 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
181 # we use "session_" prefix in inifile to get loader *after* session extension
182 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/session_%{modname}.ini
183 cp -p example.php $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
184
185 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
186 cp -p memcache.php $RPM_BUILD_ROOT%{_appdir}
187 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/config.php
188 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
189 cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
190 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
191
192 %clean
193 rm -rf $RPM_BUILD_ROOT
194
195 %post
196 %php_webserver_restart
197
198 %postun
199 if [ "$1" = 0 ]; then
200         %php_webserver_restart
201 fi
202
203 %triggerpostun -- %{name} < 3.0.4-2
204 if [ -f %{php_sysconfdir}/conf.d/%{modname}.ini.rpmsave ]; then
205         echo >&2 "Restoring old config: %{modname}.ini.rpmsave -> session_%{modname}.ini in %{php_sysconfdir}/conf.d"
206         cp -f %{php_sysconfdir}/conf.d/session_%{modname}.ini{,.rpmnew}
207         mv -f %{php_sysconfdir}/conf.d/{%{modname}.ini.rpmsave,session_%{modname}.ini}
208         %php_webserver_restart
209 fi
210
211 %triggerin web -- apache1 < 1.3.37-3, apache1-base
212 %webapp_register apache %{_webapp}
213
214 %triggerun web -- apache1 < 1.3.37-3, apache1-base
215 %webapp_unregister apache %{_webapp}
216
217 %triggerin web -- apache < 2.2.0, apache-base
218 %webapp_register httpd %{_webapp}
219
220 %triggerun web -- apache < 2.2.0, apache-base
221 %webapp_unregister httpd %{_webapp}
222
223 %triggerin web -- lighttpd
224 %webapp_register lighttpd %{_webapp}
225
226 %triggerun web -- lighttpd
227 %webapp_unregister lighttpd %{_webapp}
228
229 %files
230 %defattr(644,root,root,755)
231 %doc CREDITS README ChangeLog
232 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/session_%{modname}.ini
233 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
234 %{_examplesdir}/%{name}-%{version}
235
236 %files web
237 %defattr(644,root,root,755)
238 %dir %attr(750,root,http) %{_sysconfdir}
239 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
240 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
241 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
242 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
243 %{_appdir}
This page took 0.043691 seconds and 3 git commands to generate.