]> git.pld-linux.org Git - packages/php-pecl-mailparse.git/blob - php-pecl-mailparse.spec
1b6aec55de068246261819aa439d90b1fe777232
[packages/php-pecl-mailparse.git] / php-pecl-mailparse.spec
1 %define         _modname        mailparse
2 %define         _status         stable
3 Summary:        %{_modname} - email message manipulation
4 Summary(pl.UTF-8):      %{_modname} - obrabianie wiadomości E-mail
5 Name:           php-pecl-%{_modname}
6 Version:        2.1.5
7 Release:        1
8 License:        PHP 2.02
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
11 # Source0-md5:  0c0134fb6f5903c8fb6c9e2205263d2c
12 URL:            http://pecl.php.net/package/mailparse/
13 BuildRequires:  php-devel >= 4:5.2.0-7.2
14 BuildRequires:  rpmbuild(macros) >= 1.344
15 %{?requires_php_extension}
16 Requires:       php-common >= 4:5.0.4
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Mailparse is an extension for parsing and working with email messages.
21 It can deal with rfc822 and rfc2045 (MIME) compliant messages.
22
23 In PECL status of this package is: %{_status}.
24
25 %description -l pl.UTF-8
26 Mailparse to rozszerzenie do analizy i pracy z wiadomościami poczty
27 elektronicznej. Radzi sobie z wiadomościami zgodnymi z RFC822 oraz
28 RFC2024 (MIME).
29
30 To rozszerzenie ma w PECL status: %{_status}.
31
32 %prep
33 %setup -q -c
34
35 %build
36 cd %{_modname}-%{version}
37 phpize
38 %configure \
39         --with-%{_modname}=%{_prefix}/X11R6/include/X11/
40
41 %{__make} CPPFLAGS="-DHAVE_CONFIG_H -I%{_prefix}/X11R6/include/X11"
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
46
47 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
48 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
49 ; Enable %{_modname} extension module
50 extension=%{_modname}.so
51 EOF
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 %php_webserver_restart
58
59 %postun
60 if [ "$1" = 0 ]; then
61         %php_webserver_restart
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %doc %{_modname}-%{version}/CREDITS
67 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
68 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.053924 seconds and 2 git commands to generate.