]> git.pld-linux.org Git - packages/php-pecl-lchash.git/blob - php-pecl-lchash.spec
provide php(extname) to really be supporting multiple php versions
[packages/php-pecl-lchash.git] / php-pecl-lchash.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname lchash
3 %define         status          stable
4 Summary:        %{modname} - Libc Hash Interface
5 Summary(pl.UTF-8):      %{modname} - interfejs tablic haszujących libc
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        0.9.1
8 Release:        2
9 License:        PHP
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  1ad9261f2461db033423e797e67c301c
13 URL:            http://pecl.php.net/package/lchash/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.0
15 BuildRequires:  libtool
16 BuildRequires:  rpmbuild(macros) >= 1.650
17 %{?requires_php_extension}
18 Requires:       php(core) >= 5.0.4
19 Provides:       php(%{modname}) = %{version}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The LCHASH extension provides interface to libc implementation of hash
24 tables described by POSIX 1003.1-2001.
25
26 In PECL status of this extension is: %{status}.
27
28 %description -l pl.UTF-8
29 Rozszerzenie LCHASH dostarcza interfejsu do implementacji libc tablic
30 haszujących określonych przez standard POSIX 1003.1-2001.
31
32 To rozszerzenie ma w PECL status: %{status}.
33
34 %prep
35 %setup -qc
36 mv %{modname}-%{version}/* .
37
38 %build
39 phpize
40 %configure
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
46 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
47 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
48 ; Enable %{modname} extension module
49 extension=%{modname}.so
50 EOF
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 %php_webserver_restart
57
58 %postun
59 if [ "$1" = 0 ]; then
60         %php_webserver_restart
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %doc CREDITS EXPERIMENTAL
66 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
67 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.075723 seconds and 3 git commands to generate.