]> git.pld-linux.org Git - packages/php-pecl-imagick.git/blob - php-pecl-imagick.spec
- 0.9.5 - some new features, few bugfixes
[packages/php-pecl-imagick.git] / php-pecl-imagick.spec
1 %define         _modname        imagick
2 %define         _status         beta
3 Summary:        PHP wrapper to the Image Magick Library
4 Summary(pl):    PHP-owy wrapper do biblioteki Image Magick
5 Name:           php-pecl-%{_modname}
6 Version:        0.9.5
7 Release:        1
8 License:        PHP 2.02
9 Group:          Development/Languages/PHP
10 Source0:        http://pear.php.net/get/%{_modname}-%{version}.tgz
11 URL:            http://pear.php.net/
12 BuildRequires:  ImageMagick-devel
13 BuildRequires:  php-devel
14 Requires:       php-common
15 Obsoletes:      php-imagick
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _sysconfdir     /etc/php
19 %define         extensionsdir   %{_libdir}/php
20
21 %description
22 ImageMagick is a robust collection of tools and libraries to read,
23 write, and manipulate an image in many image formats (over 68 major
24 formats) including popular formats like TIFF, JPEG, PNG, PDF, PhotoCD,
25 and GIF. With ImageMagick you can create images dynamically, making it
26 suitable for Web applications. You can also resize, rotate, sharpen,
27 color reduce, or add special effects to an image and save your
28 completed work in the same or differing image format.
29
30 This class has in PEAR status: %{_status}.
31
32 %description -l pl
33 ImageMagick to du¿y zestaw narzêdzi i bibliotek do odczytu, zapisu i
34 modyfikowania obrazków w wielu formatach (ponad 68 g³ównych), w tym
35 popularnych, takich jak TIFF, JPEG, PNG, PDF, PhotoCD i GIF. Za pomoc±
36 ImageMagick mo¿na dynamicznie tworzyæ obrazki, co jest przydatne w
37 aplikacjach WWW. Mo¿na je tak¿e przeskalowywaæ, obracaæ, wyostrzaæ,
38 zmniejszaæ ilo¶æ kolorów - w tym samym lub innym formacie.
39
40 Ta klasa ma w PEAR status: %{_status}.
41
42 %prep
43 %setup -q -c
44
45 %build
46 cd %{_modname}-%{version}
47 phpize
48 %configure \
49         --with-%{_modname}=/usr/X11R6/include/X11/
50
51 %{__make} \
52         CPPFLAGS="-DHAVE_CONFIG_H -I/usr/X11R6/include/X11/" \
53         CFLAGS_CLEAN="%{rpmcflags}"
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT%{extensionsdir}
58
59 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post
65 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php.ini
66
67 %preun
68 if [ "$1" = "0" ]; then
69         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php.ini
70 fi
71
72 %files
73 %defattr(644,root,root,755)
74 %doc %{_modname}-%{version}/examples/{*.php,*.jpg,*.gif}
75 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.071379 seconds and 4 git commands to generate.