]> git.pld-linux.org Git - packages/php-pecl-imagick.git/blob - php-pecl-imagick.spec
test deps
[packages/php-pecl-imagick.git] / php-pecl-imagick.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         php_name        php%{?php_suffix}
6 %define         modname         imagick
7 %define         status          stable
8 Summary:        %{modname} - PHP wrapper to the Image Magick Library
9 Summary(pl.UTF-8):      %{modname} - PHP-owy wrapper do biblioteki Image Magick
10 Name:           %{php_name}-pecl-%{modname}
11 Version:        3.4.2
12 Release:        3
13 License:        PHP 3.01
14 Group:          Development/Languages/PHP
15 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
16 # Source0-md5:  3f80e35c2434636cdb5df01b221b3ffa
17 Patch0:         skip_version_check.patch
18 URL:            http://pecl.php.net/package/imagick/
19 BuildRequires:  %{php_name}-devel >= 4:5.3
20 BuildRequires:  ImageMagick-devel >= 1:6.2.4.0
21 BuildRequires:  rpmbuild(macros) >= 1.650
22 %if %{with tests}
23 BuildRequires:  %{php_name}-cli
24 BuildRequires:  %{php_name}-spl
25 BuildRequires:  ImageMagick-coder-jpeg
26 BuildRequires:  ImageMagick-coder-png
27 BuildRequires:  ImageMagick-coder-tiff
28 %endif
29 %{?requires_php_extension}
30 Requires(triggerpostun):        sed >= 4.0
31 Requires:       %{php_name}-spl
32 Suggests:       ImageMagick-coder-jpeg
33 Suggests:       ImageMagick-coder-png
34 Suggests:       ImageMagick-coder-tiff
35 Provides:       php(imagick) = %{version}
36 Obsoletes:      php-pecl-imagick < 3.1.2-2
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 ImageMagick is a robust collection of tools and libraries to read,
41 write, and manipulate an image in many image formats (over 68 major
42 formats) including popular formats like TIFF, JPEG, PNG, PDF, PhotoCD,
43 and GIF. With ImageMagick you can create images dynamically, making it
44 suitable for Web applications. You can also resize, rotate, sharpen,
45 color reduce, or add special effects to an image and save your
46 completed work in the same or differing image format.
47
48 In PECL status of this package is: %{status}.
49
50 %description -l pl.UTF-8
51 ImageMagick to duży zestaw narzędzi i bibliotek do odczytu, zapisu i
52 modyfikowania obrazków w wielu formatach (ponad 68 głównych), w tym
53 popularnych, takich jak TIFF, JPEG, PNG, PDF, PhotoCD i GIF. Za pomocą
54 ImageMagick można dynamicznie tworzyć obrazki, co jest przydatne w
55 aplikacjach WWW. Można je także przeskalowywać, obracać, wyostrzać,
56 zmniejszać ilość kolorów - w tym samym lub innym formacie.
57
58 To rozszerzenie ma w PECL status: %{status}.
59
60 %prep
61 %setup -qc
62 mv %{modname}-%{version}/* .
63 %patch0 -p1
64
65 %build
66 phpize
67 %configure \
68         php_cv_cc_dashr=false
69
70 %{__make} \
71         CFLAGS_CLEAN="%{rpmcflags}"
72
73 %if %{with tests}
74 %{__php} -n -q \
75         -d extension_dir=modules \
76         -d extension=%{php_extensiondir}/spl.so \
77         -d extension=%{modname}.so \
78         -m > modules.log
79 grep %{modname} modules.log
80
81 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
82 %{__make} test \
83         PHP_EXECUTABLE=%{__php} \
84         PHP_TEST_SHARED_SYSTEM_EXTENSIONS="spl" \
85 %endif
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
90 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
91 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
92 ; Enable %{modname} extension module
93 extension=%{modname}.so
94 EOF
95 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post
101 %php_webserver_restart
102
103 %postun
104 if [ "$1" = 0 ]; then
105         %php_webserver_restart
106 fi
107
108 %triggerpostun -- %{name} < 0.9.11-2.1
109 %{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*%{modname}\.so/d' %{php_sysconfdir}/php.ini
110
111 %files
112 %defattr(644,root,root,755)
113 %doc CREDITS
114 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
115 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
116 %{_examplesdir}/%{name}-%{version}
This page took 0.07476 seconds and 3 git commands to generate.