]> git.pld-linux.org Git - packages/php-pecl-imagick.git/blob - php-pecl-imagick.spec
22b2c94275488d8afd782247f686a0668d9ef6ec
[packages/php-pecl-imagick.git] / php-pecl-imagick.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         php_name        php%{?php_suffix}
6 %define         modname         imagick
7 %define         status          stable
8 %define         libversion      %(pkg-config --modversion MagickCore || echo ERROR)
9 Summary:        %{modname} - PHP wrapper to the Image Magick Library
10 Summary(pl.UTF-8):      %{modname} - PHP-owy wrapper do biblioteki Image Magick
11 Name:           %{php_name}-pecl-%{modname}
12 Version:        3.4.3
13 Release:        6
14 License:        PHP 3.01
15 Group:          Development/Languages/PHP
16 Source0:        https://pecl.php.net/get/%{modname}-%{version}.tgz
17 # Source0-md5:  d0ee25c007cd2a28cefccc0b9ee63a28
18 Patch0:         skip_version_check.patch
19 URL:            https://pecl.php.net/package/imagick
20 BuildRequires:  %{php_name}-devel >= 4:5.3
21 BuildRequires:  ImageMagick-devel >= 1:6.2.4.0
22 BuildRequires:  pkgconfig
23 BuildRequires:  re2c
24 BuildRequires:  rpmbuild(macros) >= 1.650
25 %if %{with tests}
26 BuildRequires:  %{php_name}-cli
27 BuildRequires:  %{php_name}-pcre
28 BuildRequires:  %{php_name}-spl
29 BuildRequires:  ImageMagick-coder-jpeg
30 BuildRequires:  ImageMagick-coder-png
31 BuildRequires:  ImageMagick-coder-tiff
32 %endif
33 %{?requires_php_extension}
34 Requires(triggerpostun):        sed >= 4.0
35 Requires:       %{php_name}-spl
36 Suggests:       ImageMagick-coder-jpeg
37 Suggests:       ImageMagick-coder-png
38 Suggests:       ImageMagick-coder-tiff
39 Provides:       php(imagick) = %{version}
40 Provides:       php(lib-imagick) = %{libversion}
41 Obsoletes:      php-pecl-imagick < 3.1.2-2
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 ImageMagick is a robust collection of tools and libraries to read,
46 write, and manipulate an image in many image formats (over 68 major
47 formats) including popular formats like TIFF, JPEG, PNG, PDF, PhotoCD,
48 and GIF. With ImageMagick you can create images dynamically, making it
49 suitable for Web applications. You can also resize, rotate, sharpen,
50 color reduce, or add special effects to an image and save your
51 completed work in the same or differing image format.
52
53 In PECL status of this package is: %{status}.
54
55 %description -l pl.UTF-8
56 ImageMagick to duży zestaw narzędzi i bibliotek do odczytu, zapisu i
57 modyfikowania obrazków w wielu formatach (ponad 68 głównych), w tym
58 popularnych, takich jak TIFF, JPEG, PNG, PDF, PhotoCD i GIF. Za pomocą
59 ImageMagick można dynamicznie tworzyć obrazki, co jest przydatne w
60 aplikacjach WWW. Można je także przeskalowywać, obracać, wyostrzać,
61 zmniejszać ilość kolorów - w tym samym lub innym formacie.
62
63 To rozszerzenie ma w PECL status: %{status}.
64
65 %prep
66 %setup -qc
67 mv %{modname}-%{version}/* .
68 %patch0 -p1
69
70 xfail() {
71         t=$1
72         cat >> $t <<-EOF
73
74         --XFAIL--
75         Skip
76         EOF
77 }
78 Test() {
79         nf=$(eval echo \$$#)
80         t=$nf; t=${t#\[}; t=${t%\]}
81         xfail $t
82 }
83 # skip failing tests
84 Test Imagick, annotateImage [tests/034_Imagick_annotateImage_basic.phpt]
85 Test Imagick, setRegistry and getRegistry [tests/150_Imagick_setregistry.phpt]
86 Test ImagickDraw, composite [tests/177_ImagickDraw_composite_basic.phpt]
87 Test ImagickDraw, setFontSize [tests/206_ImagickDraw_setFontSize_basic.phpt]
88 Test ImagickDraw, setFontFamily [tests/207_ImagickDraw_setFontFamily_basic.phpt]
89 Test ImagickDraw, setFontStretch [tests/208_ImagickDraw_setFontStretch_basic.phpt]
90 Test ImagickDraw, setFontWeight [tests/209_ImagickDraw_setFontWeight_basic.phpt]
91 Test ImagickDraw, setFontStyle [tests/210_ImagickDraw_setFontStyle_basic.phpt]
92 Test ImagickDraw, setGravity [tests/212_ImagickDraw_setGravity_basic.phpt]
93 Test ImagickDraw, setTextAlignment [tests/222_ImagickDraw_setTextAlignment_basic.phpt]
94 Test ImagickDraw, setTextAntialias [tests/223_ImagickDraw_setTextAntialias_basic.phpt]
95 Test ImagickDraw, setTextUnderColor [tests/224_ImagickDraw_setTextUnderColor_basic.phpt]
96 Test ImagickDraw, setTextDecoration [tests/225_ImagickDraw_setTextDecoration_basic.phpt]
97 Test Tutorial, psychedelicFont [tests/241_Tutorial_psychedelicFont_basic.phpt]
98 Test Tutorial, svgExample [tests/243_Tutorial_svgExample_basic.phpt]
99 Test Tutorial, psychedelicFontGif [tests/244_Tutorial_psychedelicFontGif_basic.phpt]
100 Test Imagick, Imagick::exportImagePixels [tests/256_Imagick_exportImagePixels_basic.phpt]
101 Test ImagickDraw, getTextDirection [tests/264_ImagickDraw_getTextDirection_basic.phpt]
102 Test ImagickDraw, getFontResolution [tests/266_ImagickDraw_getFontResolution_basic.phpt]
103 %ifarch x32
104 # Fail on 7.0
105 Test Imagick, quantizeImage [tests/101_Imagick_quantizeImage_basic.phpt]
106 Test Imagick, uniqueImageColors [tests/163_Imagick_uniqueImageColors_basic.phpt]
107 Test Tutorial, deconstructGif [tests/237_Tutorial_deconstructGif_basic.phpt]
108 Test ImagickPixelIterator, setIteratorRow [tests/251_ImagickPixelIterator_setIteratorRow_basic.phpt]
109 %endif
110
111 %build
112 phpize
113 %configure \
114         php_cv_cc_dashr=false
115
116 %{__make} \
117         CFLAGS_CLEAN="%{rpmcflags}"
118
119 %if %{with tests}
120 %{__php} -n -q \
121         -d extension_dir=modules \
122         -d extension=%{php_extensiondir}/pcre.so \
123         -d extension=%{php_extensiondir}/spl.so \
124         -d extension=%{modname}.so \
125         -m > modules.log
126 grep %{modname} modules.log
127
128 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
129 %{__make} test \
130         PHP_EXECUTABLE=%{__php} \
131         PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl" \
132 %endif
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
137 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
138 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
139 ; Enable %{modname} extension module
140 extension=%{modname}.so
141 EOF
142 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post
148 %php_webserver_restart
149
150 %postun
151 if [ "$1" = 0 ]; then
152         %php_webserver_restart
153 fi
154
155 %triggerpostun -- %{name} < 0.9.11-2.1
156 %{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*%{modname}\.so/d' %{php_sysconfdir}/php.ini
157
158 %files
159 %defattr(644,root,root,755)
160 %doc CREDITS
161 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
162 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
163 %{_examplesdir}/%{name}-%{version}
This page took 0.060233 seconds and 2 git commands to generate.