]> git.pld-linux.org Git - packages/php-pecl-http.git/commitdiff
- new
authorAdam Gołębiowski <adamg@pld-linux.org>
Sat, 19 Feb 2005 20:11:57 +0000 (20:11 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php-pecl-http.spec -> 1.1

php-pecl-http.spec [new file with mode: 0644]

diff --git a/php-pecl-http.spec b/php-pecl-http.spec
new file mode 100644 (file)
index 0000000..3db075e
--- /dev/null
@@ -0,0 +1,70 @@
+%define                _modname        http
+%define                _fmodname       pecl_http
+%define                _status         alpha
+
+Summary:       %{_modname} - extended HTTP support
+Summary(pl):   %{_modname} - rozszerzone wsparcie protoko³u HTTP
+Name:          php-pecl-%{_modname}
+Version:       0.4.0
+Release:       1
+License:       PHP 2.02
+Group:         Development/Languages/PHP
+Source0:       http://pecl.php.net/get/%{_fmodname}-%{version}.tgz
+# Source0-md5: 00946b14eca556ee5c223aaafbd38011
+URL:           http://pecl.php.net/package/pecl_http/
+BuildRequires: libtool
+BuildRequires: php-devel >= 3:5.0.0
+Requires:      php-common >= 3:5.0.0
+Obsoletes:     php-pear-%{_modname}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                _sysconfdir     /etc/php
+%define                extensionsdir   %{_libdir}/php
+
+%description
+Currently implemented features:
+===============================
+
+- Building absolute URIs
+- RCF compliant HTTP redirects
+- Caching by "Last-Modified" and/or ETag (with 'on the fly' option)
+- Sending data/files/streams with (multiple) ranges support
+- Negotiating user preferred language/charset
+- Convenient request functions to HEAD/GET/POST if libcurl is available
+
+In PECL status of this extension is: %{_status}.
+
+#%description -l pl
+#
+#To rozszerzenie ma w PECL status: %{_status}.
+
+%prep
+%setup -q -c
+
+%build
+cd %{_fmodname}-%{version}
+phpize
+%configure
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{extensionsdir}
+
+install %{_fmodname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}/%{_modname}.so
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
+
+%preun
+if [ "$1" = "0" ]; then
+       %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
+fi
+
+%files
+%defattr(644,root,root,755)
+%doc %{_fmodname}-%{version}/{docs,EXPERIMENTAL}
+%attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.109091 seconds and 4 git commands to generate.