]> git.pld-linux.org Git - packages/php-pecl-http.git/blob - php-pecl-http.spec
- rel 3 (new libevent)
[packages/php-pecl-http.git] / php-pecl-http.spec
1 %define         modname http
2 %define         fmodname        pecl_http
3 %define         status          stable
4 Summary:        %{modname} - extended HTTP support
5 Summary(pl.UTF-8):      %{modname} - rozszerzona obsługa protokołu HTTP
6 Name:           php-pecl-%{modname}
7 Version:        1.7.0
8 Release:        3
9 License:        BSD, revised
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{fmodname}-%{version}.tgz
12 # Source0-md5:  05ceadba4deceadc520eceefafd6eeb7
13 URL:            http://pecl.php.net/package/pecl_http/
14 BuildRequires:  curl-devel >= 7.12.3
15 BuildRequires:  openssl-devel
16 BuildRequires:  php-devel >= 3:5.0.0
17 BuildRequires:  rpmbuild(macros) >= 1.344
18 BuildRequires:  zlib-devel >= 1.2.0.4
19 %{?requires_php_extension}
20 Requires:       php-common >= 4:5.0.4
21 Obsoletes:      php-pear-%{modname}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This HTTP extension aims to provide a convenient and powerful set of
26 functionality for one of PHPs major applications.
27
28 It eases handling of HTTP urls, dates, redirects, headers and
29 messages, provides means for negotiation of clients preferred language
30 and charset, as well as a convenient way to send any arbitrary data
31 with caching and resuming capabilities.
32
33 It provides powerful request functionality, if built with CURL
34 support. Parallel requests are available for PHP 5 and greater.
35
36 Currently implemented features include:
37 - Building absolute URIs
38 - RFC compliant HTTP redirects
39 - RFC compliant HTTP date handling
40 - Parsing of HTTP headers and messages
41 - Caching by "Last-Modified" and/or ETag (with 'on the fly' option for
42   ETag generation from buffered output)
43 - Sending data/files/streams with (multiple) ranges support
44 - Negotiating user preferred language/charset
45 - Convenient request functions to HEAD/GET/POST if libcurl is
46   available
47 - HTTP auth hooks (Basic)
48 - PHP5 classes: HttpUtil, HttpResponse, HttpRequest, HttpRequestPool,
49   HttpMessage
50
51 In PECL status of this extension is: %{status}.
52
53 %description -l pl.UTF-8
54 To rozszerzenie HTTP ma na celu dostarczenie wygodnego i potężnego
55 zestawu funkcjonalności do jednego z najważniejszych zastosowań PHP.
56
57 Ułatwia obsługę adresów HTTP, dat, przekierowań, nagłówków i
58 wiadmości, dostarcza sposób do negocjacji preferowanego języka i
59 strony kodowej klienta, jak również wygodnego sposobu wysyłania
60 dowolnego rodzaju danych z możliwością keszowania oraz wznawiania
61 transferów.
62
63 Rozszerzenie dostarcza potężne możliwości zapytań, jeśli zbudowane
64 jest ze wsparciem dla CURL. Równoległe zapytania są dostępne od wersji
65 PHP 5.
66
67 Aktualnie zaimplementowane możliwości to między innymi:
68 - tworzenie bezwzględnych URI
69 - zgodne z RFC przekierowania HTTP
70 - zgodna z RFC obsługa daty HTTP
71 - przetwarzanie nagłówków i wiadomości HTTP
72 - buforowanie z użyciem "Last-Modified" i/lub ETagów (z opcję
73   generowania "w locie" ETagów z buforowanego wyjścia)
74 - wysyłanie danych/plików/strumieni z obsługą (wielu) przedziałów
75 - negocjacja preferowanego przez użytkownika języka/zestawu znaków
76 - wygodne funkcje do żądań HEAD/GET/POST jeśli dostępna jest libcurl
77 - wywołania HTTP auth (Basic)
78 - klasy PHP5: HttpUtil, HttpResponse, HttpRequest, HttpRequestPool,
79   HttpMessage
80
81 To rozszerzenie ma w PECL status: %{status}.
82
83 %prep
84 %setup -qc
85 mv %{fmodname}-%{version}/* .
86
87 %build
88 phpize
89 %configure
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
95
96 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
97 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
98 ; Enable %{modname} extension module
99 extension=%{modname}.so
100 EOF
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post
106 %php_webserver_restart
107
108 %postun
109 if [ "$1" = 0 ]; then
110         %php_webserver_restart
111 fi
112
113 %files
114 %defattr(644,root,root,755)
115 %doc KnownIssues.txt docs/*
116 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
117 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.055733 seconds and 4 git commands to generate.