]> git.pld-linux.org Git - packages/php-pecl-http.git/blob - php-pecl-http.spec
- php 5.5 rebuild
[packages/php-pecl-http.git] / php-pecl-http.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname http
3 %define         fmodname        pecl_http
4 %define         status          stable
5 Summary:        %{modname} - extended HTTP support
6 Summary(pl.UTF-8):      %{modname} - rozszerzona obsługa protokołu HTTP
7 Name:           %{php_name}-pecl-%{modname}
8 Version:        1.7.6
9 Release:        4
10 License:        BSD, revised
11 Group:          Development/Languages/PHP
12 Source0:        http://pecl.php.net/get/%{fmodname}-%{version}.tgz
13 # Source0-md5:  4926c17a24a11a9b1cf3ec613fad97cb
14 URL:            http://pecl.php.net/package/pecl_http/
15 BuildRequires:  %{php_name}-devel >= 3:5.0.0
16 BuildRequires:  curl-devel >= 7.12.3
17 BuildRequires:  openssl-devel
18 BuildRequires:  rpmbuild(macros) >= 1.650
19 BuildRequires:  zlib-devel >= 1.2.0.4
20 %{?requires_php_extension}
21 Requires:       %{php_name}-iconv
22 Requires:       %{php_name}-session
23 Requires:       php(core) >= 5.0.4
24 Provides:       php(%{modname}) = %{version}
25 Obsoletes:      php-pear-%{modname}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This HTTP extension aims to provide a convenient and powerful set of
30 functionality for one of PHPs major applications.
31
32 It eases handling of HTTP urls, dates, redirects, headers and
33 messages, provides means for negotiation of clients preferred language
34 and charset, as well as a convenient way to send any arbitrary data
35 with caching and resuming capabilities.
36
37 It provides powerful request functionality, if built with CURL
38 support. Parallel requests are available for PHP 5 and greater.
39
40 Currently implemented features include:
41 - Building absolute URIs
42 - RFC compliant HTTP redirects
43 - RFC compliant HTTP date handling
44 - Parsing of HTTP headers and messages
45 - Caching by "Last-Modified" and/or ETag (with 'on the fly' option for
46   ETag generation from buffered output)
47 - Sending data/files/streams with (multiple) ranges support
48 - Negotiating user preferred language/charset
49 - Convenient request functions to HEAD/GET/POST if libcurl is
50   available
51 - HTTP auth hooks (Basic)
52 - PHP5 classes: HttpUtil, HttpResponse, HttpRequest, HttpRequestPool,
53   HttpMessage
54
55 In PECL status of this extension is: %{status}.
56
57 %description -l pl.UTF-8
58 To rozszerzenie HTTP ma na celu dostarczenie wygodnego i potężnego
59 zestawu funkcjonalności do jednego z najważniejszych zastosowań PHP.
60
61 Ułatwia obsługę adresów HTTP, dat, przekierowań, nagłówków i
62 wiadmości, dostarcza sposób do negocjacji preferowanego języka i
63 strony kodowej klienta, jak również wygodnego sposobu wysyłania
64 dowolnego rodzaju danych z możliwością keszowania oraz wznawiania
65 transferów.
66
67 Rozszerzenie dostarcza potężne możliwości zapytań, jeśli zbudowane
68 jest ze wsparciem dla CURL. Równoległe zapytania są dostępne od wersji
69 PHP 5.
70
71 Aktualnie zaimplementowane możliwości to między innymi:
72 - tworzenie bezwzględnych URI
73 - zgodne z RFC przekierowania HTTP
74 - zgodna z RFC obsługa daty HTTP
75 - przetwarzanie nagłówków i wiadomości HTTP
76 - buforowanie z użyciem "Last-Modified" i/lub ETagów (z opcję
77   generowania "w locie" ETagów z buforowanego wyjścia)
78 - wysyłanie danych/plików/strumieni z obsługą (wielu) przedziałów
79 - negocjacja preferowanego przez użytkownika języka/zestawu znaków
80 - wygodne funkcje do żądań HEAD/GET/POST jeśli dostępna jest libcurl
81 - wywołania HTTP auth (Basic)
82 - klasy PHP5: HttpUtil, HttpResponse, HttpRequest, HttpRequestPool,
83   HttpMessage
84
85 To rozszerzenie ma w PECL status: %{status}.
86
87 %prep
88 %setup -qc
89 mv %{fmodname}-%{version}/* .
90
91 %build
92 phpize
93 %configure
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
99
100 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
101 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
102 ; Enable %{modname} extension module
103 extension=%{modname}.so
104 EOF
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post
110 %php_webserver_restart
111
112 %postun
113 if [ "$1" = 0 ]; then
114         %php_webserver_restart
115 fi
116
117 %files
118 %defattr(644,root,root,755)
119 %doc KnownIssues.txt docs/*
120 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
121 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.125159 seconds and 3 git commands to generate.