]> git.pld-linux.org Git - packages/php-pecl-hash.git/blob - php-pecl-hash.spec
18873512391c69675f2aabb402d8da10a84db7a4
[packages/php-pecl-hash.git] / php-pecl-hash.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname hash
3 %define         status          stable
4 Summary:        %{modname} - HASH Message Digest Framework
5 Summary(pl.UTF-8):      %{modname} - implementacja popularnych funkcji skrótu
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        1.5
8 Release:        1
9 License:        PHP 2.02
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  cb19f4ee392b05776788e54b51f98c83
13 URL:            http://pecl.php.net/package/hash/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.0
15 BuildRequires:  rpmbuild(macros) >= 1.650
16 %{?requires_php_extension}
17 Requires:       php(core) >= 5.0.4
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Native implementations of common message digest algorithms using a
22 generic factory method.
23
24 In PECL status of this extension is: %{status}.
25
26 %description -l pl.UTF-8
27 Natywne implementacje popularnych algorytmów skrótu.
28
29 To rozszerzenie ma w PECL status: %{status}.
30
31 %prep
32 %setup -qc
33 mv %{modname}-%{version}/* .
34
35 %build
36 phpize
37 %configure
38 %{__make}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
43 %{__make} install \
44         INSTALL_ROOT=$RPM_BUILD_ROOT \
45         EXTENSION_DIR=%{php_extensiondir}
46 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
47 ; Enable %{modname} extension module
48 extension=%{modname}.so
49 EOF
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %post
55 %php_webserver_restart
56
57 %postun
58 if [ "$1" = 0 ]; then
59         %php_webserver_restart
60 fi
61
62 %files
63 %defattr(644,root,root,755)
64 %doc README
65 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
66 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.048588 seconds and 2 git commands to generate.