]> git.pld-linux.org Git - packages/php-pecl-funcall.git/commitdiff
- unify
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 3 Jun 2010 18:29:45 +0000 (18:29 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php-pecl-funcall.spec -> 1.6

php-pecl-funcall.spec

index f3785b6d1cbbec154fb0b71ca815bc58b7dc2829..a5be8093d254ad3ffe1fb63c4e01548bc757738d 100644 (file)
@@ -1,38 +1,37 @@
-%define                _modname        funcall
-%define                _status         stable
-Summary:       %{_modname} - Add callbacks for any function/method
-Summary(pl.UTF-8):     %{_modname} - odwołania dla dowolnej funkcji / metody
-Name:          php-pecl-%{_modname}
+%define                modname funcall
+%define                status          stable
+Summary:       %{modname} - Add callbacks for any function/method
+Summary(pl.UTF-8):     %{modname} - odwołania dla dowolnej funkcji / metody
+Name:          php-pecl-%{modname}
 Version:       0.2.5
 Release:       2
 License:       New BSD
 Group:         Development/Languages/PHP
-Source0:       http://pecl.php.net/get/%{_modname}-%{version}.tgz
+Source0:       http://pecl.php.net/get/%{modname}-%{version}.tgz
 # Source0-md5: 0c4f2a989d3b21f1dab56b9959fb9fe8
 URL:           http://pecl.php.net/package/funcall/
-BuildRequires: php-devel >= 3:5.0.0
+BuildRequires: php-devel >= 4:5.0.4
 BuildRequires: rpmbuild(macros) >= 1.344
 %{?requires_php_extension}
-Requires:      php-common >= 4:5.0.4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 Call callbacks before or after specified functions/methods being
 called.
 
-In PECL status of this extension is: %{_status}.
+In PECL status of this extension is: %{status}.
 
 %description -l pl.UTF-8
 Rozszerzenie to pozwala na wykonywanie odwołań przed lub po wywołaniu
 określonej funkcji / metody.
 
-To rozszerzenie ma w PECL status: %{_status}.
+To rozszerzenie ma w PECL status: %{status}.
 
 %prep
-%setup -q -c
+%setup -qc
+mv %{modname}-%{version}/* .
 
 %build
-cd %{_modname}-%{version}
 phpize
 %configure
 %{__make}
@@ -42,12 +41,11 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
 
 %{__make} install \
-       -C %{_modname}-%{version} \
-       INSTALL_ROOT=$RPM_BUILD_ROOT \
-       EXTENSION_DIR=%{php_extensiondir}
-cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
-; Enable %{_modname} extension module
-extension=%{_modname}.so
+       EXTENSION_DIR=%{php_extensiondir} \
+       INSTALL_ROOT=$RPM_BUILD_ROOT
+cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
+; Enable %{modname} extension module
+extension=%{modname}.so
 EOF
 
 %clean
@@ -63,6 +61,6 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc %{_modname}-%{version}/{TODO,funcall.php}
-%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
-%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
+%doc TODO funcall.php
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
+%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.1259 seconds and 4 git commands to generate.