]> git.pld-linux.org Git - packages/php-pecl-funcall.git/blob - php-pecl-funcall.spec
up to 0.3.0alpha
[packages/php-pecl-funcall.git] / php-pecl-funcall.spec
1 %define         subver  alpha
2 %define         rel             1
3 %define         modname funcall
4 %define         status  stable
5 Summary:        %{modname} - Add callbacks for any function/method
6 Summary(pl.UTF-8):      %{modname} - odwołania dla dowolnej funkcji / metody
7 Name:           php-pecl-%{modname}
8 Version:        0.3.0
9 Release:        0.%{subver}.%{rel}
10 License:        New BSD
11 Group:          Development/Languages/PHP
12 Source0:        http://pecl.php.net/get/%{modname}-%{version}%{subver}.tgz
13 # Source0-md5:  65ddff0346ed4ed4fb0e3734ccf1b7d2
14 URL:            http://pecl.php.net/package/funcall/
15 BuildRequires:  php-devel >= 4:5.0.4
16 BuildRequires:  rpmbuild(macros) >= 1.344
17 %{?requires_php_extension}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Call callbacks before or after specified functions/methods being
22 called.
23
24 In PECL status of this extension is: %{status}.
25
26 %description -l pl.UTF-8
27 Rozszerzenie to pozwala na wykonywanie odwołań przed lub po wywołaniu
28 określonej funkcji / metody.
29
30 To rozszerzenie ma w PECL status: %{status}.
31
32 %prep
33 %setup -qc
34 mv %{modname}-%{version}%{?subver}/* .
35
36 %build
37 phpize
38 %configure
39 %{__make}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
44
45 %{__make} install \
46         EXTENSION_DIR=%{php_extensiondir} \
47         INSTALL_ROOT=$RPM_BUILD_ROOT
48 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
49 ; Enable %{modname} extension module
50 extension=%{modname}.so
51 EOF
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 %php_webserver_restart
58
59 %postun
60 if [ "$1" = 0 ]; then
61         %php_webserver_restart
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %doc TODO funcall.php
67 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
68 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.031584 seconds and 3 git commands to generate.