]> git.pld-linux.org Git - packages/php-pecl-fribidi.git/blob - php-pecl-fribidi.spec
- rel 7 (php 5.2.0)
[packages/php-pecl-fribidi.git] / php-pecl-fribidi.spec
1 %define         _modname        fribidi
2 %define         _status         stable
3 %define         _sysconfdir     /etc/php
4 %define         extensionsdir   %(php-config --extension-dir 2>/dev/null)
5 Summary:        %{_modname} - Implementation of the Unicode BiDi algorithm
6 Summary(pl):    %{_modname} - Implementacja algorytmu BiDi Unicode
7 Name:           php-pecl-%{_modname}
8 Version:        1.0
9 Release:        7
10 License:        PHP
11 Group:          Development/Languages/PHP
12 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
13 # Source0-md5:  360e55f049cdebc96fe797eba78399ef
14 URL:            http://pecl.php.net/package/fribidi/
15 BuildRequires:  fribidi-devel
16 BuildRequires:  php-devel >= 3:5.0.0
17 BuildRequires:  rpmbuild(macros) >= 1.322
18 %{?requires_php_extension}
19 Requires:       %{_sysconfdir}/conf.d
20 Obsoletes:      php-fribidi
21 Obsoletes:      php-pear-%{_modname}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 A PHP frontend to the FriBidi library: an implemntation of the unicode
26 Bidi algorithm, provides means of handling right-to-left text.
27
28 In PECL status of this package is: %{_status}.
29
30 %description -l pl
31 Frontend PHP do biblioteki FriBidi: implementacji algorytmu unicode
32 Bidi, dostarczaj±cego ¶rodki do obs³ugi tekstu pisanego od prawej do
33 lewej.
34
35 To rozszerzenie ma w PECL status: %{_status}.
36
37 %prep
38 %setup -q -c
39
40 %build
41 cd %{_modname}-%{version}
42 phpize
43 %configure
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
49
50 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
51 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
52 ; Enable %{_modname} extension module
53 extension=%{_modname}.so
54 EOF
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
61 [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
62
63 %postun
64 if [ "$1" = 0 ]; then
65         [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
66         [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
67 fi
68
69 %files
70 %defattr(644,root,root,755)
71 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
72 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.287899 seconds and 3 git commands to generate.