]> git.pld-linux.org Git - packages/php-pecl-fann.git/blob - php-pecl-fann.spec
provide php(extname) to really be supporting multiple php versions
[packages/php-pecl-fann.git] / php-pecl-fann.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname fann
3 %define         status          devel
4 Summary:        %{modname} - artificial neural networks
5 Summary(pl.UTF-8):      %{modname} - sztuczne sieci neuronowe
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        0.1.1
8 Release:        3
9 License:        PHP
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  5eb404da7dd1a9cec74a0ed8b5b82d47
13 URL:            http://pecl.php.net/package/fann/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.0
15 BuildRequires:  fann-devel
16 BuildRequires:  rpmbuild(macros) >= 1.650
17 %{?requires_php_extension}
18 Requires:       php(core) >= 5.0.4
19 Provides:       php(%{modname}) = %{version}
20 Obsoletes:      php-pear-%{modname}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Fann (fast artificial neural network library) implements multilayer
25 feedforward networks with support for both fully connected and sparse
26 connected networks.
27
28 In PECL status of this extension is: %{status}.
29
30 %description -l pl.UTF-8
31 Fann (biblioteka szybkich sztucznych sieci neuronowych - ang. fast
32 artificial neural network library) implementuje wielowarstwowe
33 dwustronne sieci ze wsparciem zarówno dla w pełni połączonych jak i
34 rzadko połączonych sieci.
35
36 To rozszerzenie ma w PECL status: %{status}.
37
38 %prep
39 %setup -qc
40 mv %{modname}-%{version}/* .
41
42 %build
43 phpize
44 %configure
45 %{__make}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
50 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
51 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
52 ; Enable %{modname} extension module
53 extension=%{modname}.so
54 EOF
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 %php_webserver_restart
61
62 %postun
63 if [ "$1" = 0 ]; then
64         %php_webserver_restart
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %doc CREDITS EXPERIMENTAL
70 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
71 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.074684 seconds and 3 git commands to generate.