]> git.pld-linux.org Git - packages/php-pecl-event.git/blob - php-pecl-event.spec
- rebuild with zts and debug requires
[packages/php-pecl-event.git] / php-pecl-event.spec
1 %define         _modname        event
2 %define         _status         beta
3 %define         _sysconfdir     /etc/php
4 %define         extensionsdir   %(php-config --extension-dir 2>/dev/null)
5 Summary:        %{_modname} - event scheduling engine
6 Summary(pl):    %{_modname} - silnik do planowania zdarzeñ
7 Name:           php-pecl-%{_modname}
8 Version:        0.9.1
9 Release:        3
10 License:        PHP
11 Group:          Development/Languages/PHP
12 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
13 # Source0-md5:  f009fd3519c14a027a8c85414208b61c
14 URL:            http://pecl.php.net/package/event/
15 BuildRequires:  php-devel >= 3:5.0.0
16 BuildRequires:  rpmbuild(macros) >= 1.254
17 %{?requires_php_extension}
18 Requires:       %{_sysconfdir}/conf.d
19 Obsoletes:      php-pear-%{_modname}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This is an extension to efficiently schedule IO, time and signal based
24 events using the best available IO notification mechanism for your
25 system.
26
27 This is a port of libevent to the PHP infrastructure; the API is
28 similar but not identical.
29
30 In PECL status of this extension is: %{_status}.
31
32 %description -l pl
33 To rozszerzenie pozwala na efektywne planowanie We/Wy, czasu oraz
34 opartych na sygna³ach zdarzeñ za pomoc± najlepszego dostêpnego dla
35 systemu mechanizmu powiadamiania.
36
37 Jest to port biblioteki libevent do infrastruktury PHP; API jest
38 podobne, jednak nie identyczne.
39
40 To rozszerzenie ma w PECL status: %{_status}.
41
42 %prep
43 %setup -q -c
44
45 %build
46 cd %{_modname}-%{version}
47 phpize
48 %configure
49 %{__make}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
54
55 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
56 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
57 ; Enable %{_modname} extension module
58 extension=%{_modname}.so
59 EOF
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post
65 [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
66 [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
67
68 %postun
69 if [ "$1" = 0 ]; then
70         [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
71         [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
72 fi
73
74 %files
75 %defattr(644,root,root,755)
76 %doc %{_modname}-%{version}/{CREDITS,EXPERIMENTAL}
77 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
78 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.089939 seconds and 4 git commands to generate.