]> git.pld-linux.org Git - packages/php-pecl-ecasound.git/blob - php-pecl-ecasound.spec
- more automation
[packages/php-pecl-ecasound.git] / php-pecl-ecasound.spec
1 %define         _modname        ecasound
2 Summary:        PHP wrapper to the Ecasound Library
3 Summary(pl):    PHP-owy wrapper do biblioteki Ecasound
4 Name:           php-pecl-%{_modname}
5 Version:        0.1
6 Release:        1
7 License:        PHP 2.02
8 Group:          Development/Languages/PHP
9 Source0:        http://pear.php.net/get/Ecasound-%{version}.tgz
10 URL:            http://pear.php.net/
11 BuildRequires:  libecasound-devel
12 BuildRequires:  php-devel
13 Obsoletes:      php-Ecasound
14 Requires:       php-common
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _sysconfdir     /etc/php
18 %define         extensionsdir   %{_libdir}/php
19
20 %description
21 PHP wrapper to the Ecasound Library.
22
23 %description -l pl
24 PHP-owy wrapper do biblioteki Ecasound.
25
26 %prep
27 %setup -q -c
28
29 %build
30 cd Ecasound-%{version}
31 phpize
32 %{__aclocal}
33 %configure \
34         --with-ecasound
35
36 %{__make} CPPFLAGS="-DHAVE_CONFIG_H -I/usr/X11R6/include/X11/"
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT%{extensionsdir}
41
42 install Ecasound-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %post
48 /usr/sbin/php-module-install install %{_modname} %{_sysconfdir}/php.ini
49
50 %preun
51 if [ "$1" = "0" ]; then
52         /usr/sbin/php-module-install remove %{_modname} %{_sysconfdir}/php.ini
53 fi
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Ecasound-%{version}/{CREDITS,EXPERIMENTAL,*.php}
58 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.49969 seconds and 3 git commands to generate.