]> git.pld-linux.org Git - packages/php-pecl-crack.git/commitdiff
- updated to 0.3
authorAdam Gołębiowski <adamg@pld-linux.org>
Mon, 5 Sep 2005 13:33:00 +0000 (13:33 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- switch to conf.d

Changed files:
    php-pecl-crack-m4_fixes.patch -> 1.3
    php-pecl-crack.spec -> 1.9

php-pecl-crack-m4_fixes.patch
php-pecl-crack.spec

index 67db91ac5b719e62efd4f87cf1f04d8d77bb56d1..63dc143c6b979f594b6572ab585a7b3d3b8b9d57 100644 (file)
@@ -1,12 +1,12 @@
-diff -burN php-pecl-crack-0.1.orig/crack-0.2/config.m4 php-pecl-crack-0.1/crack-0.2/config.m4
---- php-pecl-crack-0.2.orig/crack-0.2/config.m4        2004-08-09 00:03:04.849403760 +0200
-+++ php-pecl-crack-0.2/crack-0.2/config.m4     2004-08-09 00:03:21.618854416 +0200
-@@ -7,7 +7,7 @@
- if test "$PHP_CRACK" != "no"; then
--  for i in $PHP_CRACK/lib $PHP_CRACK/cracklib /usr/local/lib /usr/lib; do
-+  for i in $PHP_CRACK/lib $PHP_CRACK/cracklib /usr/local/lib /usr/lib $PHP_CRACK/lib64 /usr/lib64 /usr/local/lib64; do
-     test -f $i/libcrack.$SHLIB_SUFFIX_NAME -o -f $i/libcrack.a && CRACK_LIBDIR=$i && break
-   done
+diff -burN crack-0.3.orig/config.m4 crack-0.3/config.m4
+--- crack-0.3.orig/config.m4   2005-09-05 15:23:35.874777736 +0200
++++ crack-0.3/config.m4        2005-09-05 15:23:59.894126240 +0200
+@@ -10,7 +10,7 @@
+   if test "$PHP_CRACK" != "yes"; then
+     AC_MSG_ERROR(Only the bundled library is supported right now)
+     
+-    for i in $PHP_CRACK/lib $PHP_CRACK/cracklib /usr/local/lib /usr/lib; do
++    for i in $PHP_CRACK/lib $PHP_CRACK/cracklib /usr/local/lib /usr/lib /usr/lib64; do
+       test -f $i/libcrack.$SHLIB_SUFFIX_NAME -o -f $i/libcrack.a && CRACK_LIBDIR=$i && break
+     done
  
index d63694915892ff4571102e7c2c9133345308f8d6..ad0fdd255c99e42b457fc2f62ffe98074b287553 100644 (file)
@@ -1,28 +1,28 @@
 %define                _modname        crack
-%define                _status         stable
+%define                _status         beta
+%define                _sysconfdir     /etc/php
+%define                extensionsdir   %(php-config --extension-dir 2>/dev/null)
 
 Summary:       %{_modname} - checks if password is vulnerable to dictionary attacks
 Summary(pl):   %{_modname} - sprawdzanie czy has³o jest podatne na ataki s³ownikowe
 Name:          php-pecl-%{_modname}
-Version:       0.2
+Version:       0.3
 Release:       1
-License:       Artistic
+License:       PHP
 Group:         Development/Languages/PHP
 Source0:       http://pecl.php.net/get/%{_modname}-%{version}.tgz
-# Source0-md5: 0fbce1787086f21683f0ba5115902223
+# Source0-md5: 43a3dc3e4f2d16bf1e30ccea0d384183
 Patch0:                %{name}-m4_fixes.patch
 URL:           http://pecl.php.net/package/crack/
 BuildRequires: cracklib-devel
 BuildRequires: libtool
 BuildRequires: php-devel >= 3:5.0.0
-Requires:      php-common >= 3:5.0.0
+BuildRequires: rpmbuild(macros) >= 1.230
+%requires_eq_to php-common php-devel
 Obsoletes:     php-crack
 Obsoletes:     php-pear-%{_modname}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _sysconfdir     /etc/php
-%define                extensionsdir   %{_libdir}/php
-
 %description
 This package provides an interface to the cracklib (libcrack)
 libraries that come standard on most unix-like distributions. This
@@ -41,7 +41,7 @@ To rozszerzenie ma w PECL status: %{_status}.
 
 %prep
 %setup -q -c
-%patch0 -p1
+%patch0 -p0
 
 %build
 cd %{_modname}-%{version}
@@ -51,22 +51,31 @@ phpize
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{extensionsdir}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
+
+install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
 
 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
+; Enable %{_modname} extension module
+extension=%{_modname}.so
+EOF
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-%{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
+[ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
+[ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
 
-%preun
-if [ "$1" = "0" ]; then
-       %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
+%postun
+if [ "$1" = 0 ]; then
+       [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
+       [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
 fi
 
 %files
 %defattr(644,root,root,755)
 %doc %{_modname}-%{version}/{CREDITS,EXPERIMENTAL}
+%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/%{_modname}.ini
 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.138157 seconds and 4 git commands to generate.