]> git.pld-linux.org Git - packages/php-pecl-crack.git/commitdiff
- use new php extension related macros
authorElan Ruusamäe <glen@pld-linux.org>
Tue, 19 Dec 2006 13:40:52 +0000 (13:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php-pecl-crack.spec -> 1.18

php-pecl-crack.spec

index 0f553cecd5c91cd7039c146f25e6eae8254d68f7..89d0f166c1cbed62923b02411732d3940e029505 100644 (file)
@@ -1,7 +1,5 @@
 %define                _modname        crack
 %define                _status         beta
-%define                _sysconfdir     /etc/php
-%define                extensionsdir   %(php-config --extension-dir 2>/dev/null)
 Summary:       %{_modname} - checks if password is vulnerable to dictionary attacks
 Summary(pl):   %{_modname} - sprawdzanie czy has³o jest podatne na ataki s³ownikowe
 Name:          php-pecl-%{_modname}
@@ -15,9 +13,10 @@ Patch0:              %{name}-m4_fixes.patch
 URL:           http://pecl.php.net/package/crack/
 BuildRequires: cracklib-devel
 BuildRequires: php-devel >= 3:5.0.0
-BuildRequires: rpmbuild(macros) >= 1.322
+BuildRequires: rpmbuild(macros) >= 1.344
 %{?requires_php_extension}
 Obsoletes:     php-crack
+Requires:      php-common >= 4:5.0.4
 Obsoletes:     php-pear-%{_modname}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -49,10 +48,10 @@ phpize
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
+install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
 
-install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
-cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
+install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
 ; Enable %{_modname} extension module
 extension=%{_modname}.so
 EOF
@@ -61,17 +60,15 @@ EOF
 rm -rf $RPM_BUILD_ROOT
 
 %post
-[ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
-[ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
+%php_webserver_restart
 
 %postun
 if [ "$1" = 0 ]; then
-       [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
-       [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
+       %php_webserver_restart
 fi
 
 %files
 %defattr(644,root,root,755)
 %doc %{_modname}-%{version}/{CREDITS,EXPERIMENTAL}
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
-%attr(755,root,root) %{extensionsdir}/%{_modname}.so
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
+%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.053613 seconds and 4 git commands to generate.