]> git.pld-linux.org Git - packages/php-pecl-big_int.git/blob - php-pecl-big_int.spec
c094c460125090013b3ddb2e8e2e7e1a40620401
[packages/php-pecl-big_int.git] / php-pecl-big_int.spec
1 %define         _modname        big_int
2 %define         _status         beta
3
4 Summary:        %{_modname} - set of functions for calculations with arbitrary length integers
5 Summary(pl):    %{_modname} - zestaw funkcji do obliczeñ z u¿yciem liczb o dowolnej wielko¶ci
6 Name:           php-pecl-%{_modname}
7 Version:        0.0.5
8 Release:        1
9 License:        PHP 2.02
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
12 # Source0-md5:  d1f77c1e56fd316e29bf55e05547edbe
13 URL:            http://pecl.php.net/package/big_int/
14 BuildRequires:  libtool
15 BuildRequires:  php-devel >= 3:5.0.0
16 Requires:       php-common >= 3:5.0.0
17 Obsoletes:      php-pear-%{_modname}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _sysconfdir     /etc/php
21 %define         extensionsdir   %{_libdir}/php
22
23 %description
24 This package is useful for number theory applications.
25 For example, in two-keys cryptography.
26 See tests/RSA.php in the package for example of implementation of
27 RSA-like cryptoalgorithm.
28
29 Also the package has many bitset functions, which allow to work with
30 arbitrary length bitsets.
31
32 This package is much faster than bundled into PHP BCMath.
33 It implements almost all functions as in GMP extension,
34 but it needn't any additional external libraries.
35
36 In PECL status of this extension is: %{_status}.
37
38 #%description -l pl
39 #
40 #To rozszerzenie ma w PECL status: %{_status}.
41
42 %prep
43 %setup -q -c
44
45 %build
46 cd %{_modname}-%{version}
47 phpize
48 %configure
49 %{__make}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT%{extensionsdir}
54
55 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post
61 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
62
63 %preun
64 if [ "$1" = "0" ]; then
65         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
66 fi
67
68 %files
69 %defattr(644,root,root,755)
70 %doc %{_modname}-%{version}/{docs,tests,CREDITS,README}
71 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.054196 seconds and 2 git commands to generate.