]> git.pld-linux.org Git - packages/php-pecl-big_int.git/blob - php-pecl-big_int.spec
- updated to 1.0.1
[packages/php-pecl-big_int.git] / php-pecl-big_int.spec
1 %define         _modname        big_int
2 %define         _status         stable
3
4 Summary:        %{_modname} - set of functions for calculations with arbitrary length integers
5 Summary(pl):    %{_modname} - zestaw funkcji do obliczeñ z u¿yciem liczb o dowolnej wielko¶ci
6 Name:           php-pecl-%{_modname}
7 Version:        1.0.1
8 Release:        1
9 License:        PHP 2.02
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
12 # Source0-md5:  2426a06141ba8468feba124b5670be83
13 URL:            http://pecl.php.net/package/big_int/
14 BuildRequires:  libtool
15 BuildRequires:  php-devel >= 3:5.0.0
16 Requires:       php-common >= 3:5.0.0
17 Obsoletes:      php-pear-%{_modname}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _sysconfdir     /etc/php
21 %define         extensionsdir   %{_libdir}/php
22
23 %description
24 This package is useful for number theory applications. For example, in
25 two-keys cryptography. See tests/RSA.php in the package for example of
26 implementation of RSA-like cryptoalgorithm.
27
28 Also the package has many bitset functions, which allow to work with
29 arbitrary length bitsets.
30
31 This package is much faster than bundled into PHP BCMath. It
32 implements almost all functions as in GMP extension, but it needn't
33 any additional external libraries.
34
35 In PECL status of this extension is: %{_status}.
36
37 %description -l pl
38 Ten pakiet jest przydatny do zastosowañ z teorii liczb, na przyk³ad do
39 kryptografii z u¿yciem dwóch kluczy. Przyk³adow± implementacjê
40 algorytmu kryptograficznego podobnego do RSA mo¿na znale¼æ w tym
41 pakiecie w pliku tests/RSA.php.
42
43 Pakiet ma tak¿e wiele funkcji operuj±cych na bitach, umo¿liwiaj±cych
44 dzia³anie na zbiorach bitów dowolnej d³ugo¶ci.
45
46 Ten pakiet jest du¿o szybszy ni¿ wbudowany w PHP BCMath. Implementuje
47 prawie wszystkie funkcje z rozszerzenia GMP, ale nie wymaga ¿adnych
48 dodatkowych bibliotek zewnêtrznych.
49
50 To rozszerzenie ma w PECL status: %{_status}.
51
52 %prep
53 %setup -q -c
54
55 %build
56 cd %{_modname}-%{version}
57 phpize
58 %configure
59 %{__make}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT%{extensionsdir}
64
65 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
72
73 %preun
74 if [ "$1" = "0" ]; then
75         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
76 fi
77
78 %files
79 %defattr(644,root,root,755)
80 %doc %{_modname}-%{version}/{docs,tests,CREDITS,README}
81 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.052362 seconds and 3 git commands to generate.