]> git.pld-linux.org Git - packages/php-pecl-bcompiler.git/blob - php-pecl-bcompiler.spec
- new
[packages/php-pecl-bcompiler.git] / php-pecl-bcompiler.spec
1 %define         _modname        bcompiler
2 %define         _status         beta
3 Summary:        %{_modname} - a bytecode compiler for classes
4 Summary(pl.UTF-8):      %{_modname} - kompilator kodu bajtowego dla klas
5 Name:           php-pecl-%{_modname}
6 Version:        0.9.2
7 Release:        1
8 License:        PHP
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
11 # Source0-md5:  adebd4455ef3452775a3da2691d0ed8c
12 Patch0:         %{name}-php52.patch
13 URL:            http://pecl.php.net/package/bcompiler/
14 BuildRequires:  bzip2-devel
15 BuildRequires:  php-devel >= 3:5.0.0
16 BuildRequires:  rpmbuild(macros) >= 1.344
17 %{?requires_php_extension}
18 Requires:       php-common >= 4:5.0.4
19 Obsoletes:      php-pear-%{_modname}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 bcompiler enables you to encode your scripts in phpbytecode, enabling
24 you to protect the source. bcompiler could be used in the following
25 situations:
26 - to create a exe file of a PHP-GTK application (in conjunction with
27   other software)
28 - to create closed source libraries
29 - to provide clients with time expired software (prior to payment)
30 - to deliver close source applications
31 - for use on embedded systems, where disk space is a priority.
32
33 In PECL status of this package is: %{_status}.
34
35 %description -l pl.UTF-8
36 bcompiler pozwala na zakodowanie skryptów do kodu bajtowego PHP,
37 pozwalając na chronienie swojego kodu. bcompiler może być używany w
38 następujących sytuacjach:
39 - tworzenie plików exe dla aplikacji PHP-GTK (w połączeniu z innym
40   oprogramowaniem),
41 - tworzenie bibliotek z zamkniętym kodem,
42 - tworzenie oprogramowania z ograniczonym czasem działania (zależnym
43   od opłat),
44 - dostarczanie aplikacji o zamkniętym kodzie,
45 - użycie na systemach embedded, gdzie wielkość jest priorytetem.
46
47 To rozszerzenie ma w PECL status: %{_status}.
48
49 %prep
50 %setup -q -c
51 %patch0 -p1
52
53 %build
54 cd %{_modname}-%{version}
55 phpize
56 %configure
57
58 %{__make}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
63
64 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
65 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
66 ; Enable %{_modname} extension module
67 extension=%{_modname}.so
68 EOF
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 %php_webserver_restart
75
76 %postun
77 if [ "$1" = 0 ]; then
78         %php_webserver_restart
79 fi
80
81 %files
82 %defattr(644,root,root,755)
83 %doc %{_modname}-%{version}/examples/*
84 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
85 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.049885 seconds and 3 git commands to generate.