]> git.pld-linux.org Git - packages/php-pecl-bcompiler.git/blob - php-pecl-bcompiler.spec
- renamed package with binary pear class from php-pear-class to php-pecl-class
[packages/php-pecl-bcompiler.git] / php-pecl-bcompiler.spec
1 %define         _modname        bcompiler
2 Summary:        %{_modname} - A bytecode compiler for classes
3 Summary(pl):    %{_modname} - Kompilator kodu bajtowego dla klas
4 Name:           php-pecl-%{_modname}
5 Version:        0.4
6 Release:        1
7 License:        PHP 2.02
8 Group:          Development/Languages/PHP
9 Source0:        http://pear.php.net/get/%{_modname}-%{version}.tgz
10 URL:            http://pear.php.net/
11 BuildRequires:  libtool
12 BuildRequires:  php-devel
13 Requires:       php-common
14 Obsoletes:      php-pear-%{_modname}
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _sysconfdir     /etc/php
18 %define         extensionsdir   %{_libdir}/php
19
20 %description
21 bcompiler enables you to encode your scripts in phpbytecode, enabling
22 you to protect the source. bcompiler could be used in the following
23 situations:
24 - to create a exe file of a PHP-GTK application (in conjunction with
25   other software)
26 - to create closed source libraries
27 - to provide clients with time expired software (prior to payment)
28 - to deliver close source applications
29 - for use on embedded systems, where disk space is a priority.
30
31 %description -l pl
32 bcompiler pozwala na zakodowanie skryptów do kodu bajtowego PHP,
33 pozwalaj±c na chronienie zwojego kodu. bcompiler mo¿e byæ u¿ywany w
34 nastêpuj±cych sytuacjach:
35 - tworzenie plików exe dla aplikacji PHP-GTK (w po³±czeniu z innym
36   oprogramowaniem),
37 - tworzenie bibliotek z zamkniêtym kodem,
38 - tworzenie oprogramowania z ograniczonym czasem dzia³ania (zale¿nym
39   od op³at),
40 - dostarczanie aplikacji o zamkniêtym kodzie,
41 - u¿ycie na systemach embedded, gdzie wielko¶æ jest priorytetem.
42
43 %prep
44 %setup -q -c
45
46 %build
47 cd %{_modname}-%{version}
48 cp -f config.m4.old config.m4
49 cp -f Makefile.in.old Makefile.in
50 phpize
51 %configure
52
53 %{__make}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT%{extensionsdir}
58
59 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post
65 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
66
67 %preun
68 if [ "$1" = "0" ]; then
69         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
70 fi
71
72 %files
73 %defattr(644,root,root,755)
74 %doc %{_modname}-%{version}/examples/*
75 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.059156 seconds and 3 git commands to generate.