]> git.pld-linux.org Git - packages/php-pecl-bcompiler.git/blame - php-pecl-bcompiler.spec
provide php(extname) to really be supporting multiple php versions
[packages/php-pecl-bcompiler.git] / php-pecl-bcompiler.spec
CommitLineData
9970b416
ER
1%define php_name php%{?php_suffix}
2%define modname bcompiler
3%define status stable
4Summary: %{modname} - a bytecode compiler for classes
5Summary(pl.UTF-8): %{modname} - kompilator kodu bajtowego dla klas
6Name: %{php_name}-pecl-%{modname}
773c1040 7Version: 1.0.2
f70c0372 8Release: 4
17ca508d 9License: PHP
55fe3227 10Group: Development/Languages/PHP
9970b416 11Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
773c1040 12# Source0-md5: 99f76a5ef536d43180b41036a6a13e43
75e83565 13URL: http://pecl.php.net/package/bcompiler/
9970b416 14BuildRequires: %{php_name}-devel >= 3:5.0.0
eb42a463 15BuildRequires: bzip2-devel
9970b416 16BuildRequires: rpmbuild(macros) >= 1.650
c21b82b9 17%{?requires_php_extension}
9970b416 18Requires: %{php_name}-tokenizer
7aecdc46 19Requires: php(core) >= 5.0.4
8a9dce01 20Suggests: php-bz2
9970b416 21Obsoletes: php-pear-%{modname}
f70c0372 22Provides: php(%{modname}) = %{version}
55fe3227 23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
55fe3227 25%description
26bcompiler enables you to encode your scripts in phpbytecode, enabling
27you to protect the source. bcompiler could be used in the following
28situations:
29- to create a exe file of a PHP-GTK application (in conjunction with
30 other software)
31- to create closed source libraries
32- to provide clients with time expired software (prior to payment)
33- to deliver close source applications
34- for use on embedded systems, where disk space is a priority.
35
9970b416 36In PECL status of this package is: %{status}.
17ca508d 37
d4046066
JR
38%description -l pl.UTF-8
39bcompiler pozwala na zakodowanie skryptów do kodu bajtowego PHP,
40pozwalając na chronienie swojego kodu. bcompiler może być używany w
41następujących sytuacjach:
42- tworzenie plików exe dla aplikacji PHP-GTK (w połączeniu z innym
55fe3227 43 oprogramowaniem),
d4046066
JR
44- tworzenie bibliotek z zamkniętym kodem,
45- tworzenie oprogramowania z ograniczonym czasem działania (zależnym
46 od opłat),
47- dostarczanie aplikacji o zamkniętym kodzie,
48- użycie na systemach embedded, gdzie wielkość jest priorytetem.
55fe3227 49
9970b416 50To rozszerzenie ma w PECL status: %{status}.
17ca508d 51
55fe3227 52%prep
9970b416
ER
53%setup -qc
54mv %{modname}-%{version}/* .
55fe3227 55
56%build
55fe3227 57phpize
58%configure
59
60%{__make}
61
62%install
63rm -rf $RPM_BUILD_ROOT
f9dd92fc 64install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
9970b416
ER
65install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
66cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
67; Enable %{modname} extension module
68extension=%{modname}.so
0d8b3334 69EOF
55fe3227 70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%post
f9dd92fc 75%php_webserver_restart
55fe3227 76
0d8b3334
ER
77%postun
78if [ "$1" = 0 ]; then
f9dd92fc 79 %php_webserver_restart
55fe3227 80fi
81
82%files
83%defattr(644,root,root,755)
9970b416
ER
84%doc examples/*
85%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
86%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.08025 seconds and 4 git commands to generate.