]> git.pld-linux.org Git - packages/php-pecl-bcompiler.git/blame - php-pecl-bcompiler.spec
- use php(core) as dependency to require php version
[packages/php-pecl-bcompiler.git] / php-pecl-bcompiler.spec
CommitLineData
55fe3227 1%define _modname bcompiler
773c1040 2%define _status stable
37baf579 3Summary: %{_modname} - a bytecode compiler for classes
6575f81f 4Summary(pl.UTF-8): %{_modname} - kompilator kodu bajtowego dla klas
55fe3227 5Name: php-pecl-%{_modname}
773c1040 6Version: 1.0.2
7aecdc46 7Release: 3
17ca508d 8License: PHP
55fe3227 9Group: Development/Languages/PHP
75e83565 10Source0: http://pecl.php.net/get/%{_modname}-%{version}.tgz
773c1040 11# Source0-md5: 99f76a5ef536d43180b41036a6a13e43
75e83565 12URL: http://pecl.php.net/package/bcompiler/
eb42a463 13BuildRequires: bzip2-devel
0d8b3334 14BuildRequires: php-devel >= 3:5.0.0
f9dd92fc 15BuildRequires: rpmbuild(macros) >= 1.344
c21b82b9 16%{?requires_php_extension}
7aecdc46 17Requires: php(core) >= 5.0.4
8a9dce01
AG
18Requires: php-tokenizer
19Suggests: php-bz2
55fe3227 20Obsoletes: php-pear-%{_modname}
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
55fe3227 23%description
24bcompiler enables you to encode your scripts in phpbytecode, enabling
25you to protect the source. bcompiler could be used in the following
26situations:
27- to create a exe file of a PHP-GTK application (in conjunction with
28 other software)
29- to create closed source libraries
30- to provide clients with time expired software (prior to payment)
31- to deliver close source applications
32- for use on embedded systems, where disk space is a priority.
33
41609da2 34In PECL status of this package is: %{_status}.
17ca508d 35
d4046066
JR
36%description -l pl.UTF-8
37bcompiler pozwala na zakodowanie skryptów do kodu bajtowego PHP,
38pozwalając na chronienie swojego kodu. bcompiler może być używany w
39następujących sytuacjach:
40- tworzenie plików exe dla aplikacji PHP-GTK (w połączeniu z innym
55fe3227 41 oprogramowaniem),
d4046066
JR
42- tworzenie bibliotek z zamkniętym kodem,
43- tworzenie oprogramowania z ograniczonym czasem działania (zależnym
44 od opłat),
45- dostarczanie aplikacji o zamkniętym kodzie,
46- użycie na systemach embedded, gdzie wielkość jest priorytetem.
55fe3227 47
41609da2 48To rozszerzenie ma w PECL status: %{_status}.
17ca508d 49
55fe3227 50%prep
51%setup -q -c
52
53%build
54cd %{_modname}-%{version}
55fe3227 55phpize
56%configure
57
58%{__make}
59
60%install
61rm -rf $RPM_BUILD_ROOT
f9dd92fc 62install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
55fe3227 63
f9dd92fc
ER
64install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
65cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
0d8b3334
ER
66; Enable %{_modname} extension module
67extension=%{_modname}.so
68EOF
55fe3227 69
70%clean
71rm -rf $RPM_BUILD_ROOT
72
73%post
f9dd92fc 74%php_webserver_restart
55fe3227 75
0d8b3334
ER
76%postun
77if [ "$1" = 0 ]; then
f9dd92fc 78 %php_webserver_restart
55fe3227 79fi
80
81%files
82%defattr(644,root,root,755)
83%doc %{_modname}-%{version}/examples/*
f9dd92fc
ER
84%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
85%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.438224 seconds and 4 git commands to generate.