]> git.pld-linux.org Git - packages/php-pecl-archive.git/blob - php-pecl-archive.spec
36fe53b16f3c3335d3b4053a14aff91a0a4c11f0
[packages/php-pecl-archive.git] / php-pecl-archive.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname         archive
3 %define         status          beta
4 Summary:        %{modname} - manipulate tar/cpio archives
5 Summary(pl.UTF-8):      %{modname} - obróbka archiwów tar/cpio
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        0.2
8 Release:        18
9 License:        PHP 3.01
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  1b121440b2c460b2a1af46e31f23e46e
13 Patch0:         php-pecl-%{modname}-php52.patch
14 URL:            http://pecl.php.net/package/archive/
15 BuildRequires:  %{php_name}-devel >= 3:5.0.4
16 BuildRequires:  libarchive-devel
17 BuildRequires:  rpmbuild(macros) >= 1.650
18 %{?requires_php_extension}
19 Provides:       php(%{modname}) = %{version}
20 Obsoletes:      php-pecl-archive < 0.2-17
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 archive extension allows to read and write tar and cpio archives using
25 libarchive.
26
27 In PECL status of this extension is: %{status}.
28
29 %description -l pl.UTF-8
30 Rozszerzenie archive pozwala na odczyt i zapis archiwów tar oraz cpio
31 przy użyciu biblioteki libarchive.
32
33 To rozszerzenie ma w PECL status: %{status}.
34
35 %prep
36 %setup -qc
37 mv %{modname}-%{version}/* .
38 %patch0 -p0
39
40 %build
41 phpize
42 %configure
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
48 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
49 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
50 ; Enable %{modname} extension module
51 extension=%{modname}.so
52 EOF
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 %php_webserver_restart
59
60 %postun
61 if [ "$1" = 0 ]; then
62         %php_webserver_restart
63 fi
64
65 %files
66 %defattr(644,root,root,755)
67 %doc API.txt CREDITS tests
68 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
69 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.070644 seconds and 2 git commands to generate.