]> git.pld-linux.org Git - packages/php-pecl-amfext.git/blob - php-pecl-amfext.spec
bf8b25ec110393f0b2b7d36a0fe98c2b5dee8833
[packages/php-pecl-amfext.git] / php-pecl-amfext.spec
1 %define         _modname        amfext
2 %define         _status         beta
3 Summary:        %{_modname} - ActionScript Message Format extension
4 Summary(pl.UTF-8):      %{_modname} - rozszerzenie ActionScript Message Format
5 Name:           php-pecl-%{_modname}
6 Version:        0.9.2
7 Release:        1
8 License:        PHP 2.02
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
11 # Source0-md5:  c5899ca580f19ef7f057b6ea41c2d236
12 URL:            http://pecl.php.net/package/amfext/
13 BuildRequires:  php-devel >= 3:5.0.0
14 BuildRequires:  rpmbuild(macros) >= 1.344
15 %{?requires_php_extension}
16 Requires:       php-common >= 4:5.0.4
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Allows to encode and decode PHP data in ActionScript Message Format
21 (AMF) version 0 and 3.
22
23 In PECL status of this extension is: %{_status}.
24
25 %description -l pl.UTF-8
26 Rozszerzenie to pozwala (de)kodowanie danych PHP do formatu
27 ActionScript Message Format (AMF) w wersji 0 i 3.
28
29 To rozszerzenie ma w PECL status: %{_status}.
30
31 %prep
32 %setup -q -c
33
34 %build
35 cd %{_modname}-%{version}
36 phpize
37 %configure
38 %{__make}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
43
44 %{__make} install \
45         -C %{_modname}-%{version} \
46         INSTALL_ROOT=$RPM_BUILD_ROOT \
47         EXTENSION_DIR=%{php_extensiondir}
48 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
49 ; Enable %{_modname} extension module
50 extension=%{_modname}.so
51 EOF
52
53 mv -f $RPM_BUILD_ROOT%{php_extensiondir}/{amf,%{_modname}}.so
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 %php_webserver_restart
60
61 %postun
62 if [ "$1" = 0 ]; then
63         %php_webserver_restart
64 fi
65
66 %files
67 %defattr(644,root,root,755)
68 %doc %{_modname}-%{version}/{CREDITS,README}
69 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
70 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.105185 seconds and 2 git commands to generate.