]> git.pld-linux.org Git - packages/php-pecl-adodb.git/blob - php-pecl-adodb.spec
- release 2
[packages/php-pecl-adodb.git] / php-pecl-adodb.spec
1 %define         modname adodb
2 %define         ver             %(echo %{version} | tr -d .)
3 Summary:        ADOdb PHP extension
4 Name:           php-pecl-%{modname}
5 Version:        5.0.4
6 Release:        2
7 License:        BSD
8 Group:          Development/Languages/PHP
9 Source0:        http://phplens.com/lens/dl/adodb-ext-%{ver}.zip
10 # Source0-md5:  4efb3fc1f5a347f20be9222885779688
11 URL:            http://adodb.sourceforge.net/
12 BuildRequires:  php-devel >= 3:5.0.0
13 BuildRequires:  rpmbuild(macros) >= 1.553
14 BuildRequires:  sed >= 4.0
15 BuildRequires:  unzip
16 %{?requires_php_extension}
17 Requires:       php-common >= 4:5.0.4
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 ADOdb PHP extension provides up to 100% speedup by replacing parts of
22 ADOdb with C code. ADOdb will auto-detect if this extension is
23 installed and use it automatically.
24
25 %prep
26 %setup -q -c
27 mv %{modname}-%{ver}/* .
28 %undos README.txt
29
30 %build
31 phpize
32 %configure
33 %{__make}
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
38
39 %{__make} install \
40         EXTENSION_DIR=%{php_extensiondir} \
41         INSTALL_ROOT=$RPM_BUILD_ROOT
42
43 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
44 ; Enable %{modname} extension module
45 extension=%{modname}.so
46 EOF
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %post
52 %php_webserver_restart
53
54 %postun
55 if [ "$1" = 0 ]; then
56         %php_webserver_restart
57 fi
58
59 %files
60 %defattr(644,root,root,755)
61 %doc CREDITS README.txt
62 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
63 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.107289 seconds and 4 git commands to generate.