]> git.pld-linux.org Git - packages/php-pear.git/blob - php-pear.spec
- v1.3.10: Symfony, Symfony/Component
[packages/php-pear.git] / php-pear.spec
1 Summary:        PEAR - PHP Extension and Application Repository
2 Summary(pl.UTF-8):      PEAR - rozszerzenie PHP i repozytorium aplikacji
3 Name:           php-pear
4 Version:        1.3.10
5 Release:        1
6 Epoch:          4
7 License:        Public Domain
8 Group:          Development/Languages/PHP
9 Source0:        php-channel-prov.php
10 Source100:      update-channels.sh
11 Source1:        channel-phing.xml
12 Source2:        channel-phpdb.xml
13 Source3:        channel-firephp.xml
14 Source4:        channel-symfony.xml
15 Source5:        channel-phpunit.xml
16 Source6:        channel-phpseclib.xml
17 Source7:        channel-horde.xml
18 Source8:        channel-rc.xml
19 Source9:        channel-ezc.xml
20 Source10:       channel-propel.xml
21 Source11:       channel-docblox.xml
22 Source12:       channel-michelf.xml
23 Source13:       channel-phpmd.xml
24 Source14:       channel-pdepend.xml
25 Source15:       channel-symfony2.xml
26 BuildRequires:  /usr/bin/php
27 BuildRequires:  php-pear-PEAR >= 1:1.9.0
28 BuildRequires:  rpmbuild(macros) >= 1.570
29 Obsoletes:      php-pear-additional_classes
30 Obsoletes:      php4-pear
31 Conflicts:      php-pear-PEAR < 1:1.7.2-10
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         __reg_provides  php %{SOURCE0}
36
37 # find channel provides
38 %define         _use_internal_dependency_generator 0
39 %define         __find_provides %{__reg_provides}
40 %define         __find_requires %{nil}
41
42 # avoid rpm 4.4.9 adding rm -rf buildroot, we need the dirs to check consistency
43 %define         __spec_clean_body       %{nil}
44
45 %description
46 PEAR - PHP Extension and Application Repository.
47
48 Please note that this package provides only basic directory structure.
49 If you want to use base PEAR classes (PEAR.php, PEAR/*.php), that come
50 with PHP, please install appropriate php-pear-* (php-pear-PEAR,
51 php-PEAR-Archive_Tar, etc) packages.
52
53 %description -l pl.UTF-8
54 PEAR (PHP Extension and Application Repository) - rozszerzenie PHP i
55 repozytorium aplikacji.
56
57 Należy pamiętać, że ten pakiet dostarcza tylko podstawową strukturę
58 katalogów. Aby użyć podstawowych klas PEAR (PEAR.php PEAR/*.php),
59 dostarczanych z PHP, należy zainstalować odpowiednie pakiety
60 php-pear-* (php-pear-PEAR, php-pear-Archive_Tar, itp).
61
62 %prep
63 %setup -qcT
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT%{php_pear_dir}/{.registry,bin,data,tests}
68
69 # add extra channels
70 %{__pear} -c pearrc config-set php_dir $RPM_BUILD_ROOT%{php_pear_dir}
71 for xml in $(awk '/^Source[0-9]+:.+channel-.+.xml$/ {print $NF}' %{_specdir}/%{name}.spec); do
72         %{__pear} -c pearrc channel-add %{_sourcedir}/$xml
73 done
74
75 while read dir; do
76         install -d $RPM_BUILD_ROOT$dir
77 done <<EOF
78 %{php_pear_dir}/Archive
79 %{php_pear_dir}/Auth
80 %{php_pear_dir}/Cache
81 %{php_pear_dir}/Console
82 %{php_pear_dir}/Contact
83 %{php_pear_dir}/Crypt
84 %{php_pear_dir}/Event
85 %{php_pear_dir}/File
86 %{php_pear_dir}/Genealogy
87 %{php_pear_dir}/Gtk
88 %{php_pear_dir}/Gtk2
89 %{php_pear_dir}/HTML
90 %{php_pear_dir}/HTML/QuickForm
91 %{php_pear_dir}/HTML/Table
92 %{php_pear_dir}/HTML/Template
93 %{php_pear_dir}/HTTP
94 %{php_pear_dir}/HTTP/WebDAV
95 %{php_pear_dir}/HTTP/WebDAV/Tools
96 %{php_pear_dir}/Horde
97 %{php_pear_dir}/Horde/Stream
98 %{php_pear_dir}/Horde/Text
99 %{php_pear_dir}/Horde/Xml
100 %{php_pear_dir}/I18N
101 %{php_pear_dir}/Image
102 %{php_pear_dir}/MP3
103 %{php_pear_dir}/Mail
104 %{php_pear_dir}/Math
105 %{php_pear_dir}/Net
106 %{php_pear_dir}/Net/UserAgent
107 %{php_pear_dir}/Numbers
108 %{php_pear_dir}/PHP
109 %{php_pear_dir}/Payment
110 %{php_pear_dir}/QA
111 %{php_pear_dir}/Science
112 %{php_pear_dir}/Services
113 %{php_pear_dir}/Structures
114 %{php_pear_dir}/Symfony
115 %{php_pear_dir}/Symfony/Component
116 %{php_pear_dir}/Testing
117 %{php_pear_dir}/Text
118 %{php_pear_dir}/Text/CAPTCHA
119 %{php_pear_dir}/Text/Spell
120 %{php_pear_dir}/URI
121 %{php_pear_dir}/Validate
122 %{php_pear_dir}/Validate/Finance
123 %{php_pear_dir}/VersionControl
124 %{php_pear_dir}/XML
125 EOF
126
127 %clean
128 cd $RPM_BUILD_ROOT%{php_pear_dir}
129
130 check_channel_dirs() {
131         RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
132         TMPFILE=$(mktemp)
133         find .channels .registry -type d | LC_ALL=C sort > $TMPFILE
134
135         # find finds also '.', so use option -B for diff
136         if rpm -qplv %{_rpmdir}/$RPMFILE | sed -ne '/^d/s,^.*%{php_pear_dir}/\.,.,p' | LC_ALL=C sort | diff -uB $TMPFILE - ; then
137                 rm -rf $RPM_BUILD_ROOT
138         else
139                 echo -e "\nNot so good, some channel directories are not included in package\n"
140                 exit 1
141         fi
142         rm -f $TMPFILE
143 }
144 check_channel_dirs
145
146 %files
147 %defattr(644,root,root,755)
148 %dir %{php_pear_dir}
149 %{php_pear_dir}/*
150
151 %ghost %{php_pear_dir}/.depdblock
152 %ghost %{php_pear_dir}/.depdb
153 %ghost %{php_pear_dir}/.filemap
154 %ghost %{php_pear_dir}/.lock
155
156 %dir %{php_pear_dir}/.registry
157 %dir %{php_pear_dir}/.channels
158 %dir %{php_pear_dir}/.channels/.alias
159
160 # core channels
161 %{php_pear_dir}/.channels/__uri.reg
162 %{php_pear_dir}/.registry/.channel.__uri
163
164 %{php_pear_dir}/.channels/.alias/pear.txt
165 %{php_pear_dir}/.channels/pear.php.net.reg
166
167 %{php_pear_dir}/.channels/.alias/pecl.txt
168 %{php_pear_dir}/.channels/pecl.php.net.reg
169 %{php_pear_dir}/.registry/.channel.pecl.php.net
170
171 %{php_pear_dir}/.channels/.alias/phpdocs.txt
172 %{php_pear_dir}/.channels/doc.php.net.reg
173 %{php_pear_dir}/.registry/.channel.doc.php.net
174
175 # addon channels
176 %{php_pear_dir}/.channels/.alias/phpunit.txt
177 %{php_pear_dir}/.channels/pear.phpunit.de.reg
178 %{php_pear_dir}/.registry/.channel.pear.phpunit.de
179
180 %{php_pear_dir}/.channels/.alias/phing.txt
181 %{php_pear_dir}/.channels/pear.phing.info.reg
182 %{php_pear_dir}/.registry/.channel.pear.phing.info
183
184 %{php_pear_dir}/.channels/.alias/phpdb.txt
185 %{php_pear_dir}/.channels/pear.phpdb.org.reg
186 %{php_pear_dir}/.registry/.channel.pear.phpdb.org
187
188 %{php_pear_dir}/.channels/.alias/firephp.txt
189 %{php_pear_dir}/.channels/pear.firephp.org.reg
190 %{php_pear_dir}/.registry/.channel.pear.firephp.org
191
192 %{php_pear_dir}/.channels/.alias/symfony.txt
193 %{php_pear_dir}/.channels/pear.symfony-project.com.reg
194 %{php_pear_dir}/.registry/.channel.pear.symfony-project.com
195
196 %{php_pear_dir}/.channels/.alias/phpseclib.txt
197 %{php_pear_dir}/.channels/phpseclib.sourceforge.net.reg
198 %{php_pear_dir}/.registry/.channel.phpseclib.sourceforge.net
199
200 %{php_pear_dir}/.channels/.alias/horde.txt
201 %{php_pear_dir}/.channels/pear.horde.org.reg
202 %{php_pear_dir}/.registry/.channel.pear.horde.org
203
204 %{php_pear_dir}/.channels/.alias/rc.txt
205 %{php_pear_dir}/.channels/pear.roundcube.net.reg
206 %{php_pear_dir}/.registry/.channel.pear.roundcube.net
207
208 %{php_pear_dir}/.channels/.alias/ezc.txt
209 %{php_pear_dir}/.channels/components.ez.no.reg
210 %{php_pear_dir}/.registry/.channel.components.ez.no
211
212 %{php_pear_dir}/.channels/.alias/propel.txt
213 %{php_pear_dir}/.channels/pear.propelorm.org.reg
214 %{php_pear_dir}/.registry/.channel.pear.propelorm.org
215
216 %{php_pear_dir}/.channels/.alias/docblox.txt
217 %{php_pear_dir}/.channels/pear.docblox-project.org.reg
218 %{php_pear_dir}/.registry/.channel.pear.docblox-project.org
219
220 %{php_pear_dir}/.channels/.alias/michelf.txt
221 %{php_pear_dir}/.channels/pear.michelf.com.reg
222 %{php_pear_dir}/.registry/.channel.pear.michelf.com
223
224 %{php_pear_dir}/.channels/.alias/pdepend.txt
225 %{php_pear_dir}/.channels/pear.pdepend.org.reg
226 %{php_pear_dir}/.registry/.channel.pear.pdepend.org
227
228 %{php_pear_dir}/.channels/.alias/phpmd.txt
229 %{php_pear_dir}/.channels/pear.phpmd.org.reg
230 %{php_pear_dir}/.registry/.channel.pear.phpmd.org
231
232 %{php_pear_dir}/.channels/.alias/symfony2.txt
233 %{php_pear_dir}/.channels/pear.symfony.com.reg
234 %{php_pear_dir}/.registry/.channel.pear.symfony.com
This page took 0.104134 seconds and 3 git commands to generate.