]> git.pld-linux.org Git - packages/php-pear-XML_XPath.git/blob - php-pear-XML_XPath.spec
- rel 2
[packages/php-pear-XML_XPath.git] / php-pear-XML_XPath.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          XML
3 %define         _subclass       XPath
4 %define         _status         stable
5 %define         _pearname       %{_class}_%{_subclass}
6
7 Summary:        %{_pearname} - XPath/DOM XML manipulation, maneuvering and query interface
8 Summary(pl.UTF-8):      %{_pearname} - interfejs do obróbki i zapytań XPath/DOM XML
9 Name:           php-pear-%{_pearname}
10 Version:        1.2.4
11 Release:        2
12 License:        PHP 2.02
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
15 # Source0-md5:  b0af5c50625373a13400db23b85b4924
16 Patch0:         %{name}-path_fix.patch
17 URL:            http://pear.php.net/package/XML_XPath/
18 BuildRequires:  php-pear-PEAR
19 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
20 BuildRequires:  rpmbuild(macros) >= 1.300
21 Requires:       php(domxml)
22 Requires:       php-common < 3:5.0.0
23 Requires:       php-common >= 3:4.2.1
24 Requires:       php-pear
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The PEAR::XML_XPath class provides an XPath/DOM XML manipulation,
30 maneuvering and query interface.
31
32 The class allows for easy manipulation, maneuvering and querying of a
33 DOMXML tree using both XPath queries and DOM walk functions. It uses
34 an internal pointer for all methods on which the action is performed.
35 Results from an DOM/XPath query are returned as an XPath_Result
36 object, which contains an internal array of DOM nodes and which
37 extends the common DOM class and hence contains all the DOM functions
38 from the main object to run on each of the elements in the internal
39 array. This class tries to hold as close as possible to the DOM
40 Recommendation. You MUST have the domxml extension to use this class.
41
42 The XML_XPath class was inspired by a class maintained by Nigel
43 Swinson called phpxpath. The phpxpath class does not rely on PHP
44 xmldom functions and is therefore a sibling to this class:
45 <http://sourceforge.net/projects/phpxpath/>.
46
47 In PEAR status of this package is: %{_status}.
48
49 %description -l pl.UTF-8
50 Klasa PEAR::XML_XPath udostępnia interfejs do obróbki, manewrowania i
51 zapytań XPath/DOM XML.
52
53 Klasa ta pozwala na łatwe manipulowanie, manewrowanie i odpytywanie
54 drzewa DOMXML przy użyciu zapytań XPath i funkcji chodzących DOM.
55 Używa wewnętrznego wskaźnika dla wszystkich metod, na których jest
56 wykonywana akcja. Wyniki zapytań DOM/XPath są zwracane jako obiekt
57 XPath_Result, który zawiera wewnętrzną tablicę węzłów DOM i rozszerza
58 ogólną klasę DOM, przez co zawiera wszystkie funkcje DOM z głównego
59 obiektu, które można uruchamiać na każdym z elementów wewnętrznej
60 tablicy. Ta klasa próbuje być najbliżej rekomendacji DOM na ile to
61 możliwe. Aby używać tej klasy, trzeba mieć rozszerzenie domxml.
62
63 Klasa XML_XPath była inspirowana klasą phpxpath utrzymywaną przez
64 Nigela Swinsona. Klasa phpxpath nie polega na funkcjach PHP xmldom,
65 dlatego jest siostrzana dla tej klasy:
66 <http://sourceforge.net/projects/phpxpath/>.
67
68 Ta klasa ma w PEAR status: %{_status}.
69
70 %prep
71 %pear_package_setup
72 cd ./%{php_pear_dir}/%{_class}
73 %patch0 -p2
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT%{php_pear_dir}
78 %pear_package_install
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc install.log
86 %doc docs/%{_pearname}/docs/*
87 %dir %{php_pear_dir}/%{_class}/%{_subclass}
88 %{php_pear_dir}/.registry/*.reg
89 %{php_pear_dir}/%{_class}/*.php
90 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
This page took 0.061942 seconds and 3 git commands to generate.