]> git.pld-linux.org Git - packages/php-pear-XML_SaxFilters.git/blob - php-pear-XML_SaxFilters.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/php-pear-XML_SaxFilters.git] / php-pear-XML_SaxFilters.spec
1 %define         _status         beta
2 %define         _pearname       XML_SaxFilters
3 Summary:        %{_pearname} - a framework for building XML filters using the SAX API
4 Summary(pl.UTF-8):      %{_pearname} - tworzenie filtrów XML za pomocą API SAX
5 Name:           php-pear-%{_pearname}
6 Version:        0.3.0
7 Release:        6
8 License:        PHP
9 Group:          Development/Languages/PHP
10 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
11 # Source0-md5:  205e7ab8b5fcc63e131ad6c96f7aa09c
12 URL:            http://pear.php.net/package/XML_SaxFilters/
13 BuildRequires:  php-pear-PEAR
14 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
15 BuildRequires:  rpmbuild(macros) >= 1.300
16 Requires:       php(core) >= 4.1.0
17 Requires:       php-pear
18 Requires:       php-pear-XML_HTMLSax
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 XML_SaxFilters provides a foundation for using Sax filters in PHP. The
24 original code base was developed by Luis Argerich and published at
25 http://phpxmlclasses.sourceforge.net/show_doc.php?class=class_sax_filters.html.
26 Luis discussed how SaxFilters work, using the Sourceforge classes as
27 an example, in Chapter 10 of Wrox "PHP 4 XML". Luis kindly gave
28 permission to modify the code and license for inclusion in PEAR.
29
30 This version of the Sax Filters makes significant changes to Luis's
31 original code (backwards compatibility is definately broken),
32 seperating abstract classes from interfaces, providing interfaces for
33 data readers and writers and providing methods to help parse XML
34 documents recursively with filters (for example
35 AbstractFilter::setParent()) for documents where the structure can
36 vary significantly.
37
38 Sax Filtering is an approach to making parsing XML documents with Sax
39 modular and easy to maintain. The parser delegates events to a child
40 filter which may in turn delegate events to another filter. In general
41 it's possible to implement filters for a document which are as
42 flexible and powerful as DOM.
43
44 In PEAR status of this package is: %{_status}.
45
46 %description -l pl.UTF-8
47 XML_SaxFilters dostarcza podstawy do użycia filtrów Sax w PHP.
48 Originalny kod został opracowany przez Luisa Argericha i opublikowany
49 pod adresem
50 http://phpxmlclasses.sourceforge.net/show_doc.php?class=class_sax_filters.html.
51 Luis poddał dyskusji sposób, w jaki działają SaxFilters, używając jako
52 przykładu klas Sourceforge, w rozdziale 10 "PHP 4 XML" wydawnictwa
53 Wrox. Luis zezwolił na modyfikację kodu i licencji tak, aby klasa ta
54 mogła zostać dołączona do PEAR.
55
56 Ta wersja Filtrów Sax wprowadza znaczące zmiany w stosunku do
57 oryginalnego kodu Luisa (wsteczna zgodność nie została zachowana),
58 oddzielając abstrakcyjne klasy od interfejsu, dostarczając interfejsy
59 do odczytu i zapisu danych oraz metody wspomagające rekursywne
60 parsowanie dokumentów XML (na przykład AbstractFilter::setParent())
61 dla dokumentów, których struktura może się znacząco różnić.
62
63 Celem filtrowania Sax jest sprawienie, iż parsowanie dokumetnów będzie
64 modularne i łatwe do zarządzania. Parser wysyła zdarzenia to filtra
65 dziecka, które z kolei może wysłać zdarzenia do innego filtra. Możliwe
66 jest zaimplementowanie filtrów, które będą tak elastyczne i potężne
67 jak DOM.
68
69 Ta klasa ma w PEAR status: %{_status}.
70
71 %prep
72 %pear_package_setup
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT%{php_pear_dir}
77 %pear_package_install
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc install.log
85 %doc docs/%{_pearname}/docs/*
86 %{php_pear_dir}/.registry/*.reg
87 %{php_pear_dir}/XML/*.php
88 %{php_pear_dir}/XML/SaxFilters
This page took 0.156374 seconds and 3 git commands to generate.