]> git.pld-linux.org Git - packages/php-pear-System_Command.git/blob - php-pear-System_Command.spec
- simplifications in %install.
[packages/php-pear-System_Command.git] / php-pear-System_Command.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          System
3 %define         _subclass       Command
4 %define         _pearname       %{_class}_%{_subclass}
5 Summary:        %{_class}_%{_subclass} - commandline execution interface
6 Summary(pl):    %{_class}_%{_subclass} - interfejs do wykonywania poleceñ systemowych
7 Name:           php-pear-%{_pearname}
8 Version:        1.0
9 Release:        1
10 License:        PHP 2.02
11 Group:          Development/Languages/PHP
12 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
13 URL:            http://pear.php.net/
14 BuildRequires:  rpm-php-pearprov
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Running functions from the commandline can be dangerous if the proper
20 precautions are not taken to escape the shell arguments and reaping
21 the exit status properly. This class give a formal interface to both,
22 so that you can run a system command as comfortably as you would run a
23 php function, which full pear error handling as results on failure.
24
25 %description -l pl
26 U¿ywanie funkcji z poleceñ systemowych mo¿e byæ niebezpieczne, je¶li
27 nie wykona³o siê odpowiedniego przygotowania parametrów i sprawdzenia
28 kodu wyj¶cia. Ta klasa daje formalny interfejs do obu rzeczy, co
29 pozwala na wywo³ywanie poleceñ systemowych w sposób tak wygodny, jak
30 wywo³anie funkcji php, która u¿ywa obs³ugi b³êdów PEAR-a w przypadku
31 niepowodzenia.
32
33 %prep
34 %setup -q -c
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}
39
40 install %{_pearname}-%{version}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %dir %{php_pear_dir}/%{_class}
48 %{php_pear_dir}/%{_class}/*.php
This page took 0.039566 seconds and 4 git commands to generate.