]> git.pld-linux.org Git - packages/php-pear-System_Command.git/blob - php-pear-System_Command.spec
- added missing status information (it is stable)
[packages/php-pear-System_Command.git] / php-pear-System_Command.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          System
3 %define         _subclass       Command
4 %define         _status         stable
5 %define         _pearname       %{_class}_%{_subclass}
6
7 Summary:        %{_pearname} - commandline execution interface
8 Summary(pl):    %{_pearname} - interfejs do wykonywania poleceñ systemowych
9 Name:           php-pear-%{_pearname}
10 Version:        1.0.1
11 Release:        1
12 License:        PHP 2.02
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
15 # Source0-md5:  1cdc6c0797c719cf5c0cc4d21f1be058
16 URL:            http://pear.php.net/package/System_Command/
17 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
18 Requires:       php-pear
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Running functions from the commandline can be dangerous if the proper
24 precautions are not taken to escape the shell arguments and reaping
25 the exit status properly. This class give a formal interface to both,
26 so that you can run a system command as comfortably as you would run a
27 php function, which full pear error handling as results on failure.
28
29 This class has in PEAR status: %{_status}.
30
31 %description -l pl
32 U¿ywanie funkcji z poleceñ systemowych mo¿e byæ niebezpieczne, je¶li
33 nie wykona³o siê odpowiedniego przygotowania parametrów i sprawdzenia
34 kodu wyj¶cia. Ta klasa daje formalny interfejs do obu rzeczy, co
35 pozwala na wywo³ywanie poleceñ systemowych w sposób tak wygodny, jak
36 wywo³anie funkcji php, która u¿ywa obs³ugi b³êdów PEAR-a w przypadku
37 niepowodzenia.
38
39 Ta klasa ma w PEAR status: %{_status}.
40
41 %prep
42 %setup -q -c
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}
47
48 install %{_pearname}-%{version}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %dir %{php_pear_dir}/%{_class}
56 %{php_pear_dir}/%{_class}/*.php
This page took 0.050268 seconds and 4 git commands to generate.