]> git.pld-linux.org Git - packages/php-pear-PHP_Fork.git/commitdiff
- shorter en summary
authorAdam Gołębiowski <adamg@pld-linux.org>
Mon, 29 Mar 2004 15:57:10 +0000 (15:57 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added pl summary
- more readable en description (also removed unnecessary portions)

Changed files:
    php-pear-PHP_Fork.spec -> 1.2

php-pear-PHP_Fork.spec

index 51693165b98b11e9a16494298f919f4e921bda8a..a95710dc4405a279eb8305c1133309deee1d4af9 100644 (file)
@@ -4,8 +4,8 @@
 %define                _status         beta
 %define                _pearname       %{_class}_%{_subclass}
 
-Summary:       %{_pearname} - Wrapper around the pcntl_fork() stuff with a API set like Java language
-#Summary(pl):  %{_pearname} -
+Summary:       %{_pearname} - Wrapper for pcntl_fork() with Java-like API
+Summary(pl):   %{_pearname} - Wrapper dla pcntl_fork() z API zbli¿onym do Javy
 Name:          php-pear-%{_pearname}
 Version:       0.1
 Release:       1
@@ -20,28 +20,27 @@ BuildArch:  noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-PHP_Fork class. Wrapper around the pcntl_fork() stuff
-with a API set like Java language.
-Practical usage is done by extending this class, and re-defining
-the run() method.
+PHP_Fork class. Wrapper around the pcntl_fork() stuff with a API set
+like Java language. Practical usage is done by extending this class,
+and re-defining the run() method.
 [see basic example]
+
 This way PHP developers can enclose logic into a class that extends
 PHP_Fork, then execute the start() method that forks a child process.
-Communications with the forked process is ensured by using a Shared Memory
-Segment; by using a user-defined signal and this shared memory developers
-can access to child process methods that returns a serializable variable.
-The shared variable space can be accessed with the tho methods:
-o void setVariable($name, $value)
-o mixed getVariable($name)
+Communications with the forked process is ensured by using a Shared
+Memory Segment; by using a user-defined signal and this shared memory
+developers can access to child process methods that returns a
+serializable variable.
+
+The shared variable space can be accessed with the two methods:
+- void setVariable($name, $value)
+- mixed getVariable($name)
+
 $name must be a valid PHP variable name;
 $value must be a variable or a serializable object.
-Resources (db connections, streams, etc.) cannot be serialized and so they're not correctly handled.
-Requires PHP build with --enable-cli --with-pcntl --enable-shmop.
-Only runs on *NIX systems, because Windows lacks of the pcntl ext.
-@example simple_controller.php shows how to attach a controller to started pseudo-threads.
-@example exec_methods.php shows a workaround to execute methods into the child process.
-@example passing_vars.php shows variable exchange between the parent process and started pseudo-threads.
-@example basic.php a basic example, only two pseudo-threads that increment a counter simultaneously.
+
+Resources (db connections, streams, etc.) cannot be serialized and so
+they're not correctly handled.
 
 This class has in PEAR status: %{_status}.
 
This page took 0.036887 seconds and 4 git commands to generate.