]> git.pld-linux.org Git - packages/php-pear-PEAR_PackageFileManager.git/blob - php-pear-PEAR_PackageFileManager.spec
446d5f86a2b8007c35c4f225c2ba48b798deff25
[packages/php-pear-PEAR_PackageFileManager.git] / php-pear-PEAR_PackageFileManager.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          PEAR
3 %define         _subclass       PackageFileManager
4 %define         _status         stable
5 %define         _pearname       %{_class}_%{_subclass}
6
7 Summary:        %{_pearname} - takes an existing package.xml file and updates it with a new filelist and changelog
8 Summary(pl):    %{_pearname} - aktualizacja package.xml (dodanie nowej listy plików oraz listy zmian)
9 Name:           php-pear-%{_pearname}
10 Version:        1.5.2
11 Release:        2
12 Epoch:          0
13 License:        PHP 2.02
14 Group:          Development/Languages/PHP
15 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
16 # Source0-md5:  76b2b2f9c3491e451caf11adebf04df6
17 URL:            http://pear.php.net/package/PEAR_PackageFileManager/
18 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
19 Requires:       php-pear
20 Requires:       php-pear-PEAR >= 1:1.1
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _noautoreq      'pear(PHP/CompatInfo.*)' 'pear(XML/Tree.*)'
25
26 %description
27 This package revolutionizes the maintenance of PEAR packages. With a
28 few parameters, the entire package.xml is automatically updated with a
29 listing of all files in a package.
30
31 Features include:
32 - reads an existing package.xml file, and only changes the
33   release/changelog
34 - a plugin system for retrieving files in a directory. Currently two
35   plugins exist, one for standard recursive directory content listing,
36   and one that reads CVS/Entries and generates a file listing based on
37   the contents of a checked out CVS repository
38 - incredibly flexible options for assigning install roles to
39   files/directories
40 - ability to ignore any file based on a * ? wildcard-enabled string
41 - ability to manage dependencies
42 - can output the package.xml in any directory, and read in the
43   package.xml from any directory
44 - can specify a different name for the package.xml file
45
46 In PEAR status of this package is: %{_status}.
47
48 %description -l pl
49 Ten pakiet rewolucjonizuje zarz±dzanie pakietami PEAR. Za pomoc± kilku
50 parametrów mo¿liwe jest automatyczne zaktualizowanie package.xml o
51 listê plików danego pakietu.
52
53 Mo¿liwo¶ci pakietu:
54 - wczytuje istniej±cy plik package.xml i zmienia w nim tylko
55   release/changelog
56 - system wtyczek s³u¿±cych do skompletowania listy plików w katalogu.
57   Aktualnie istniej± dwie takie wtyczki - jedna do standardowego
58   rekursywnego przegl±dania katalogów, druga do odczytu do generowania
59   listy plików na podstawie CVS/Entries.
60 - niesamowicie elastyczne opcje do okre¶lania roli podczas instalacji
61   dla plików/katalogów [FIXME?]
62 - mo¿liwo¶æ ignorowania plików na podstawie wildcardów * ?
63 - mo¿liwo¶æ do zarz±dzania zale¿no¶ciami
64 - mo¿liwo¶æ zapisu pliku package.xml do dowolnego katalogu oraz
65   odczytu tego pliku z dowolnego katalogu
66 - mo¿na okre¶liæ dla pliku package.xml inn± nazwê
67
68 Ta klasa ma w PEAR status: %{_status}.
69
70 %package tests
71 Summary:        Tests for PEAR::%{_pearname}
72 Summary(pl):    Testy dla PEAR::%{_pearname}
73 Group:          Development
74 Requires:       %{name} = %{epoch}:%{version}-%{release}
75 AutoReq:        no
76
77 %description tests
78 Tests for PEAR::%{_pearname}.
79
80 %description tests -l pl
81 Testy dla PEAR::%{_pearname}.
82
83 %prep
84 %pear_package_setup
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT%{php_pear_dir}
89 %pear_package_install
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post
95 if [ -f %{_docdir}/%{name}-%{version}/optional-packages.txt ]; then
96         cat %{_docdir}/%{name}-%{version}/optional-packages.txt
97 fi
98
99 %files
100 %defattr(644,root,root,755)
101 %doc install.log optional-packages.txt
102 %doc docs/%{_pearname}/examples
103 %{php_pear_dir}/.registry/*.reg
104 %dir %{php_pear_dir}/%{_class}/%{_subclass}
105 %{php_pear_dir}/%{_class}/*.php
106 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
107
108 %files tests
109 %defattr(644,root,root,755)
110 %{php_pear_dir}/tests/*
This page took 0.05523 seconds and 2 git commands to generate.