]> git.pld-linux.org Git - packages/php-pear-HTML_Template_IT.git/blob - php-pear-HTML_Template_IT.spec
- updated to 1.1.4
[packages/php-pear-HTML_Template_IT.git] / php-pear-HTML_Template_IT.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          HTML
3 %define         _subclass       Template
4 %define         _status         stable
5 %define         _pearname       %{_class}_%{_subclass}_IT
6
7 Summary:        %{_pearname} - Integrated Templates
8 Summary(pl):    %{_pearname} - zintegrowane szablony
9 Name:           php-pear-%{_pearname}
10 Version:        1.1.4
11 Release:        1
12 License:        PHP 2.02
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
15 # Source0-md5:  8c1d1c859a0b079a9bc60065cb0503d5
16 URL:            http://pear.php.net/package/HTML_Template_IT/
17 BuildRequires:  php-pear-PEAR
18 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
19 Requires:       php-pear
20 Requires:       php-pear-PEAR-core
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 # included in tests
25 %define         _noautoreq 'pear(Console_TestListener.php)' 'pear(IT_api_testcase.php)' 'pear(IT_usage_testcase.php)'
26
27 %description
28 HTML_Template_IT: Simple template API. The Isotemplate API is somewhat
29 tricky for a beginner although it is the best one you can build.
30 template::parse() [phplib template = Isotemplate] requests you to name
31 a source and a target where the current block gets parsed into. Source
32 and target can be block names or even handler names. This API gives
33 you a maximum of fexibility but you always have to know what you do
34 which is quite unusual for PHP skripter like me. I noticed that I do
35 not any control on which block gets parsed into which one. If all
36 blocks are within one file, the script knows how they are nested and
37 in which way you have to parse them. IT knows that inner1 is a child
38 of block2, there's no need to tell him about this. Features:
39  - Nested blocks,
40  - Include external file,
41  - Custom tags format (default {mytag}).
42
43 HTML_Template_ITX: With this class you get the full power of the
44 phplib template class. You may have one file with blocks in it but you
45 have as well one main file and multiple files one for each block. This
46 is quite useful when you have user configurable websites. Using blocks
47 not in the main template allows you to modify some parts of your
48 layout easily.
49
50 In PEAR status of this package is: %{_status}.
51
52 %description -l pl
53 HTML_Template_IT - proste API do szablonów. API Isotemplate (template
54 z phplib) jest nieco zawi³e dla pocz±tkuj±cych, ale jest najlepszym
55 jakie mo¿na uzyskaæ. template::parse() wymaga nazwania ¼ród³a i celu,
56 do którego przetworzony bêdzie aktualny blok. ¬ród³o i cel mog± byæ
57 nazwami bloków lub nawet nazwami funkcji obs³uguj±cych. To API daje
58 maksymaln± elastyczno¶æ, ale wymaga zawsze wiedzy, co siê robi, co nie
59 jest normalnym stanem dla niektórych autorów skryptów PHP, takich jak
60 autor tego modu³u. Zauwa¿y³ on, ¿e nie potrzebuje ¿adnej kontroli,
61 który blok zostaje przetworzony na który. Je¿eli wszystkie bloki s± w
62 jednym pliku, skrypt wie, jak s± zagnie¿d¿one i w jaki sposób powinny
63 zostaæ przetworzone. IT wie, ¿e inner1 jest potomkiem block2, nie ma
64 potrzeby podawania mu tych informacji. Mo¿liwo¶ci:
65  - zagnie¿d¿one bloki,
66  - do³±czanie zewnêtrznych plików,
67  - w³asny format znaczników (domy¶lnie {mytag}).
68
69 HTML_Template_ITX - ta klasa daje ca³± si³ê klasy szablonów z phplib.
70 Mo¿na mieæ jeden plik z blokami, ale mo¿na tak¿e mieæ jeden g³ówny
71 plik i wiele plików zawieraj±cych po jednym bloku. Jest to przydatne,
72 aby pozwoliæ u¿ytkownikowi na konfigurowalne serwisy. Przez u¿ycie
73 bloków spoza g³ównego szablonu pozwala siê na ³atwe modyfikowanie
74 niektórych czê¶ci wygl±du.
75
76 Ta klasa ma w PEAR status: %{_status}.
77
78 %package tests
79 Summary:        Tests for PEAR::%{_pearname}
80 Summary(pl):    Testy dla PEAR::%{_pearname}
81 Group:          Development/Languages/PHP
82 Requires:       %{name} = %{version}-%{release}
83 AutoReq:        no
84 AutoProv:       no
85
86 %description tests
87 Tests for PEAR::%{_pearname}.
88
89 %description tests -l pl
90 Testy dla PEAR::%{_pearname}.
91
92 %prep
93 %pear_package_setup
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT%{php_pear_dir}
98 %pear_package_install
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files
104 %defattr(644,root,root,755)
105 %doc install.log
106 %{php_pear_dir}/.registry/*.reg
107 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
108
109 %files tests
110 %defattr(644,root,root,755)
111 %{php_pear_dir}/tests/*
This page took 0.031197 seconds and 3 git commands to generate.