]> git.pld-linux.org Git - packages/php-pear-DB_NestedSet.git/blob - php-pear-DB_NestedSet.spec
f7240bb72372b5e78dc7ba7107be832102a1cdd2
[packages/php-pear-DB_NestedSet.git] / php-pear-DB_NestedSet.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          DB
3 %define         _subclass       NestedSet
4 %define         _status         beta
5 %define         _pearname       %{_class}_%{_subclass}
6
7 Summary:        %{_pearname} - API to build and query nested sets
8 Summary(pl.UTF-8):   %{_pearname} - API to tworzenia i wykonywania zagnieżdżonych zapytań
9 Name:           php-pear-%{_pearname}
10 Version:        1.3.6
11 Release:        4
12 Epoch:          0
13 License:        PHP 2.02
14 Group:          Development/Languages/PHP
15 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
16 # Source0-md5:  556e7afbf740c0f18b35bfd820fd75b9
17 URL:            http://pear.php.net/package/DB_NestedSet/
18 BuildRequires:  php-pear-PEAR
19 BuildRequires:  rpm-php-pearprov >= 4.4.2-12
20 BuildRequires:  rpmbuild(macros) >= 1.300
21 Requires:       php-pear
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 # included in tests
26 %define         _noautoreq 'pear(TestBase.php)' 'pear(UnitTest.php)'
27
28 %description
29 DB_NestedSet lets you create trees with infinite depth inside a
30 relational database. The package provides a way to:
31 - create/update/delete nodes
32 - query nodes, trees and subtrees
33 - copy (clone) nodes, trees and subtrees
34 - move nodes, trees and subtrees
35 - call event handlers on specific events like on node deletion
36 - output the tree with
37   - PEAR::HTML_TreeMenu
38   - TigraMenu (http://www.softcomplex.com/products/tigra_menu/)
39 - It also features caching of SQL queries using PEAR::Cache.
40
41 In PEAR status of this package is: %{_status}.
42
43 %description -l pl.UTF-8
44 DB_NestedSet pozwala na tworzenie drzew nieskończonej długości
45 wewnątrz relacyjnych baz danych. Pakiet umożliwia:
46 - tworzenie/modyfikowanie/usuwanie węzłów
47 - odpytywanie węzłów, drzew i poddrzew
48 - kopiowanie (klonowanie) węzłów, drzew i poddrzew
49 - przenoszenie węzłów, drzew i poddrzew
50 - wywoływanie procedur obsługi dla określonych zdarzeń typu usuwanie
51   węzła
52 - pokazanie drzewa przy użyciu:
53   - PEAR::HTML_TreeMenu
54   - TigraMenu (http://www.softcomplex.com/products/tigra_menu/)
55 - może także buforować zapytania SQL przy użyciu PEAR::Cache.
56
57 Ta klasa ma w PEAR status: %{_status}.
58
59 %package tests
60 Summary:        Tests for PEAR::%{_pearname}
61 Summary(pl.UTF-8):   Testy dla PEAR::%{_pearname}
62 Group:          Development/Languages/PHP
63 Requires:       %{name} = %{epoch}:%{version}-%{release}
64 AutoReq:        no
65 AutoProv:       no
66
67 %description tests
68 Tests for PEAR::%{_pearname}.
69
70 %description tests -l pl.UTF-8
71 Testy dla PEAR::%{_pearname}.
72
73 %prep
74 %pear_package_setup
75
76 # fix tests
77 cd ./%{php_pear_dir}/tests/%{_pearname}/tests
78 # mac line endings!
79 sed -i -e 's,\r,\n,g' index.php
80
81 # make it suitable after install
82 sed -i -e 's,NestedSet.php,DB/NestedSet.php,' *.php
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT%{php_pear_dir}
87 %pear_package_install
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc install.log
95 %doc docs/%{_pearname}/docs/*
96 %{php_pear_dir}/.registry/*.reg
97 %dir %{php_pear_dir}/%{_class}/%{_subclass}
98 %{php_pear_dir}/%{_class}/*.php
99 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
100
101 %files tests
102 %defattr(644,root,root,755)
103 %{php_pear_dir}/tests/*
This page took 0.058902 seconds and 2 git commands to generate.