]> git.pld-linux.org Git - packages/php-dirs.git/commitdiff
- rel 2; process /var/run/php-ug for itk, too auto/th/php-dirs-1.5-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 11 Dec 2014 12:15:39 +0000 (13:15 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 11 Dec 2014 12:15:39 +0000 (13:15 +0100)
php-dirs.spec
php-session.sh

index 89988135129d0d41efceb1e746f2b9e0205bcc01..cf0b01cf47946e234571149a612b3db8980b1cb4 100644 (file)
@@ -5,7 +5,7 @@ Summary:        Common dirs for different PHP versions
 Summary(pl.UTF-8):     Wspólne katalogi dla różnych wersji PHP
 Name:          php-dirs
 Version:       1.5
-Release:       1
+Release:       2
 License:       GPL
 Group:         Base
 Source0:       php-session.sh
index c5d99a27aa76de883ded55b94101f73fd45185a1..a12c1a68b39f512f61954a34647ab2b9235d62d1 100755 (executable)
@@ -2,30 +2,33 @@
 
 [ -x /usr/sbin/tmpwatch ] || exit 0
 
-session_dir=/var/run/php
-# find minimum gc time from any of the php engines
-gc_time=0
-for php in php php4 php52 php53 php54 php55; do
-       gc=
-       if [ -x /usr/bin/$php ]; then
-               gc=$($php -r 'echo max(round(ini_get("session.gc_maxlifetime")/3600), 1);' 2> /dev/null)
-       elif [ -r /etc/$php/php.ini ]; then
-               gc=$(awk -F"=" '/^session.gc_maxlifetime[ \t]*=/ { t=sprintf("%d", ($2/3600)); if (t<1) { t=1; }; print t; exit;}' /etc/$php/php.ini)
-       fi
-       [ -n "$gc" ] || continue
+for session_dir in /var/run/php /var/run/php-ug; do
+       [ ! -d "$session_dir" ] && continue
 
-       if [ "$gc" -lt "$gc_time" ] || [ $gc_time -eq 0 ]; then
-               gc_time=$gc
-       fi
-done
+       # find minimum gc time from any of the php engines
+       gc_time=0
+       for php in php php4 php52 php53 php54 php55; do
+               gc=
+               if [ -x /usr/bin/$php ]; then
+                       gc=$($php -r 'echo max(round(ini_get("session.gc_maxlifetime")/3600), 1);' 2> /dev/null)
+               elif [ -r /etc/$php/php.ini ]; then
+                       gc=$(awk -F"=" '/^session.gc_maxlifetime[ \t]*=/ { t=sprintf("%d", ($2/3600)); if (t<1) { t=1; }; print t; exit;}' /etc/$php/php.ini)
+               fi
+               [ -n "$gc" ] || continue
+
+               if [ "$gc" -lt "$gc_time" ] || [ $gc_time -eq 0 ]; then
+                       gc_time=$gc
+               fi
+       done
 
-[ $gc_time -gt 0 ] || exit 0
+       [ $gc_time -gt 0 ] || continue
 
-# use tmpwatch with --test to remove only files matching to 'sess_*' pattern
-/usr/sbin/tmpwatch $gc_time $session_dir --test | while read action type file; do
-       case "$action $type $file" in
-       'removing file '*/sess_*)
-               rm "$file"
-               ;;
-       esac
+       # use tmpwatch with --test to remove only files matching to 'sess_*' pattern
+       /usr/sbin/tmpwatch $gc_time $session_dir --test | while read action type file; do
+               case "$action $type $file" in
+               'removing file '*/sess_*)
+                       rm "$file"
+                       ;;
+               esac
+       done
 done
This page took 0.074131 seconds and 4 git commands to generate.