]> git.pld-linux.org Git - packages/php-dirs.git/blob - php-dirs.spec
- http group creation as group is used in %files
[packages/php-dirs.git] / php-dirs.spec
1 Summary:        Common dirs for different PHP versions
2 Name:           php-dirs
3 Version:        0.9
4 Release:        0.1
5 License:        GPL
6 Group:          Base
7 BuildRequires:  rpmbuild(macros) >= 1.202
8 Requires(postun):       /usr/sbin/groupdel
9 Requires(pre):  /usr/bin/getgid
10 Requires(pre):  /usr/sbin/groupadd
11 Provides:       group(http)
12 BuildArch:      noarch
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         _tmpwatchdir    /etc/tmpwatch
16
17 %description
18 Common directories for PHP version 4 and version 5.
19
20 %prep
21
22 %install
23 rm -rf $RPM_BUILD_ROOT
24 install -d $RPM_BUILD_ROOT{%{_datadir}/php,/var/run/php,%{_tmpwatchdir}}
25
26 echo '/var/run/php 720' > $RPM_BUILD_ROOT%{_tmpwatchdir}/php.conf
27
28 %clean
29 rm -rf $RPM_BUILD_ROOT
30
31 %pre
32 %groupadd -g 51 http
33
34 %postun
35 if [ "$1" = "0" ]; then
36         %groupremove http
37 fi
38
39 %files
40 %defattr(644,root,root,755)
41 %dir %{_datadir}/php
42 %attr(770,root,http) %dir %verify(not group mode) /var/run/php
43 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_tmpwatchdir}/php.conf
This page took 0.065614 seconds and 3 git commands to generate.