]> git.pld-linux.org Git - packages/php-composer-ca-bundle.git/blob - php-composer-ca-bundle.spec
use system ca-certificates package
[packages/php-composer-ca-bundle.git] / php-composer-ca-bundle.spec
1 %define         php_min_version 5.3.2
2 %define         pkgname ca-bundle
3 %include        /usr/lib/rpm/macros.php
4 Summary:        Lets you find a path to the system CA bundle, and includes a fallback to the Mozilla CA bundle
5 Name:           php-composer-%{pkgname}
6 Version:        1.0.2
7 Release:        1
8 License:        MIT
9 Group:          Development/Languages/PHP
10 Source0:        https://github.com/composer/ca-bundle/archive/%{version}/%{pkgname}-%{version}.tar.gz
11 # Source0-md5:  0e08430806fbcad13b8e568a854e5b4e
12 URL:            https://github.com/composer/ca-bundle
13 Patch0:         system-ca-certs.patch
14 Requires:       ca-certificates >= 20141019-3
15 Requires:       php(core) >= %{php_min_version}
16 Requires:       php(openssl)
17 Requires:       php(pcre)
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Small utility library that lets you find a path to the system CA
23 bundle, and includes a fallback to the Mozilla CA bundle.
24
25 Originally written as part of composer/composer, now extracted and
26 made available as a stand-alone library.
27
28 %prep
29 %setup -q -n %{pkgname}-%{version}
30 %patch0 -p1
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 install -d $RPM_BUILD_ROOT%{php_data_dir}/Composer/CaBundle
35 cp -a src/* $RPM_BUILD_ROOT%{php_data_dir}/Composer/CaBundle
36
37 %clean
38 rm -rf $RPM_BUILD_ROOT
39
40 %files
41 %defattr(644,root,root,755)
42 %doc README.md LICENSE
43 %dir %{php_data_dir}/Composer
44 %{php_data_dir}/Composer/CaBundle
This page took 0.093224 seconds and 3 git commands to generate.