]> git.pld-linux.org Git - packages/photoqt.git/blob - photoqt.spec
- release 3 (by relup.sh)
[packages/photoqt.git] / photoqt.spec
1 #
2 # Conditional build:
3 %bcond_without  gmagick         # GraphicsMagick support
4
5 %define qt_ver  5.3
6 Summary:        Simple but powerful Qt-based image viewer
7 Summary(pl.UTF-8):      Prosta, ale mająca duże możliwości przeglądarka obrazków oparta na Qt
8 Name:           photoqt
9 Version:        1.4.1
10 Release:        3
11 License:        GPL v2+
12 Group:          X11/Applications
13 #Source0Download: http://photoqt.org/down/
14 Source0:        http://photoqt.org/pkgs/%{name}-%{version}.tar.gz
15 # Source0-md5:  f708ccf9f4e01ad3fac2e893c4f14014
16 URL:            http://photoqt.org/
17 %{?with_gmagick:BuildRequires:  GraphicsMagick-c++-devel}
18 BuildRequires:  Qt5Core-devel >= %{qt_ver}
19 BuildRequires:  Qt5Gui-devel >= %{qt_ver}
20 BuildRequires:  Qt5Quick-devel >= %{qt_ver}
21 BuildRequires:  Qt5Sql-devel >= %{qt_ver}
22 BuildRequires:  Qt5Svg-devel >= %{qt_ver}
23 BuildRequires:  Qt5Widgets-devel >= %{qt_ver}
24 BuildRequires:  cmake >= 2.8
25 BuildRequires:  exiv2-devel
26 BuildRequires:  libraw-devel
27 BuildRequires:  libstdc++-devel >= 6:4.7
28 BuildRequires:  qt5-build >= %{qt_ver}
29 BuildRequires:  qt5-linguist >= %{qt_ver}
30 BuildRequires:  qt5-qmake >= %{qt_ver}
31 BuildRequires:  rpmbuild(macros) >= 1.596
32 Requires(post,postun):  desktop-file-utils
33 Requires(post,postun):  gtk-update-icon-cache
34 Requires:       Qt5Core >= %{qt_ver}
35 Requires:       Qt5Gui >= %{qt_ver}
36 Requires:       Qt5Quick >= %{qt_ver}
37 Requires:       Qt5Sql >= %{qt_ver}
38 Requires:       Qt5Sql-sqldriver-sqlite3 >= %{qt_ver}
39 Requires:       Qt5Svg >= %{qt_ver}
40 Requires:       Qt5Widgets >= %{qt_ver}
41 Requires:       hicolor-icon-theme
42 # psd imageformat plugin
43 Suggests:       libqpsd-qt5
44 Suggests:       xcftools
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Simple but powerful Qt-based image viewer.
49
50 %description -l pl.UTF-8
51 Prosta, ale mająca duże możliwości przeglądarka obrazków oparta na Qt.
52
53 %prep
54 %setup -q
55
56 %build
57 install -d build
58 cd build
59 %cmake .. \
60         %{!?with_gmagick:-DGM=OFF} \
61         -DEXIV2=ON
62
63 %{__make}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 %{__make} -C build install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 %update_desktop_database
75 %update_icon_cache hicolor
76
77 %postun
78 %update_desktop_database
79 %update_icon_cache hicolor
80
81 %files
82 %defattr(644,root,root,755)
83 %doc README CHANGELOG
84 %attr(755,root,root) %{_bindir}/photoqt
85 %{_datadir}/appdata/photoqt.appdata.xml
86 %{_desktopdir}/photoqt.desktop
87 %{_iconsdir}/hicolor/*x*/apps/photoqt.png
This page took 0.068198 seconds and 3 git commands to generate.