]> git.pld-linux.org Git - packages/pfstools.git/commitdiff
- up to 2.0.6 auto/th/pfstools-2.0.6-1
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 26 May 2017 20:19:59 +0000 (22:19 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 26 May 2017 20:19:59 +0000 (22:19 +0200)
pfstools-2.0.4-maptype.patch [deleted file]
pfstools-2.0.4-octinstall.patch [deleted file]
pfstools.spec

diff --git a/pfstools-2.0.4-maptype.patch b/pfstools-2.0.4-maptype.patch
deleted file mode 100644 (file)
index f6d4653..0000000
+++ /dev/null
@@ -1,104 +0,0 @@
-diff -up pfstools-2.0.4/src/octave/pfsput.cpp.maptype pfstools-2.0.4/src/octave/pfsput.cpp
---- pfstools-2.0.4/src/octave/pfsput.cpp.maptype       2015-07-15 11:58:23.000000000 +0200
-+++ pfstools-2.0.4/src/octave/pfsput.cpp       2015-07-20 11:49:05.445680473 +0200
-@@ -52,9 +52,9 @@ DEFUN_DLD( pfsput, args, , helpString)
-     return retval;
-   }
-   
--  octave_scalar_map pfsStream = args(0).map_value();
-+  octave_map pfsStream = args(0).map_value();
--  octave_scalar_map::const_iterator itFH = pfsStream.seek( "FH" );
-+  octave_map::const_iterator itFH = pfsStream.seek( "FH" );
-   if( itFH == pfsStream.end() ||
-     !pfsStream.contents( itFH )(0).is_real_scalar() )
-   {
-@@ -65,7 +65,7 @@ DEFUN_DLD( pfsput, args, , helpString)
-   // Check mode
-   {                             
--    octave_scalar_map::const_iterator itMode = pfsStream.seek( "MODE" );
-+    octave_map::const_iterator itMode = pfsStream.seek( "MODE" );
-     if( itMode == pfsStream.end() || !pfsStream.contents( itMode )(0).is_string() )
-     {
-       error( SCRIPT_NAME ": MODE field missing in the structure or it has wrong type");
-@@ -80,8 +80,8 @@ DEFUN_DLD( pfsput, args, , helpString)
-   // Get width & height
-   int width, height;
-   {                             
--    octave_scalar_map::const_iterator itCols = pfsStream.seek( "columns" );
--    octave_scalar_map::const_iterator itRows = pfsStream.seek( "rows" );
-+    octave_map::const_iterator itCols = pfsStream.seek( "columns" );
-+    octave_map::const_iterator itRows = pfsStream.seek( "rows" );
-     if( itCols == pfsStream.end() || itRows == pfsStream.end() ||
-       !pfsStream.contents( itCols )(0).is_real_scalar() ||
-       !pfsStream.contents( itRows )(0).is_real_scalar() )
-@@ -94,9 +94,9 @@ DEFUN_DLD( pfsput, args, , helpString)
-   }
-   // Get channels
--  octave_scalar_map channels;
-+  octave_map channels;
-   {
--    octave_scalar_map::const_iterator itChannels = pfsStream.seek( "channels" );
-+    octave_map::const_iterator itChannels = pfsStream.seek( "channels" );
-     if( itChannels == pfsStream.end() ||
-       !pfsStream.contents( itChannels )(0).is_map() )
-     {
-@@ -111,7 +111,7 @@ DEFUN_DLD( pfsput, args, , helpString)
-     pfs::Frame *frame = ctx.createFrame( width, height );
-     // For each channel in the 'channels' map
--    for( octave_scalar_map::iterator itCh = channels.begin(); itCh != channels.end(); itCh++ ) {
-+    for( octave_map::iterator itCh = channels.begin(); itCh != channels.end(); itCh++ ) {
-       std::string channelName = channels.key(itCh);
-       if( !channels.contents( itCh )(0).is_real_matrix() ) {
-@@ -135,15 +135,15 @@ DEFUN_DLD( pfsput, args, , helpString)
-     // Copy frame tags
-     {
--      octave_scalar_map::const_iterator itTags = pfsStream.seek( "tags" );
-+      octave_map::const_iterator itTags = pfsStream.seek( "tags" );
-       if( itTags != pfsStream.end() ) {
-         if( !pfsStream.contents( itTags )(0).is_map() )
-         {
-           throw pfs::Exception( "'tags' field must be a structure" );  
-         }
-         
--        octave_scalar_map_map tags = pfsStream.contents( itTags )(0).map_value();
--        for( octave_scalar_map::iterator itTag = tags.begin(); itTag != tags.end(); itTag++ ) {
-+        octave_map tags = pfsStream.contents( itTags )(0).map_value();
-+        for( octave_map::iterator itTag = tags.begin(); itTag != tags.end(); itTag++ ) {
-           std::string tagName = tags.key(itTag);
-           if( !tags.contents( itTag )(0).is_string() ) 
-@@ -156,14 +156,14 @@ DEFUN_DLD( pfsput, args, , helpString)
-     // Copy channel tags
-     {
--      octave_scalar_map::const_iterator itChTags = pfsStream.seek( "channelTags" );
-+      octave_map::const_iterator itChTags = pfsStream.seek( "channelTags" );
-       if( itChTags != pfsStream.end() ) {
-         if( !pfsStream.contents( itChTags )(0).is_map() )
-         {
-           throw pfs::Exception( "'channelTags' field must be a structure" );  
-         }
--        octave_scalar_map tagChannels = pfsStream.contents( itChTags )(0).map_value();
--        for( octave_scalar_map::iterator itCh = tagChannels.begin(); itCh != tagChannels.end(); itCh++ ) {
-+        octave_map tagChannels = pfsStream.contents( itChTags )(0).map_value();
-+        for( octave_map::iterator itCh = tagChannels.begin(); itCh != tagChannels.end(); itCh++ ) {
-           std::string channelName = tagChannels.key(itCh);
-           if( !tagChannels.contents( itCh )(0).is_map() ) {
-             throw pfs::Exception( "each channelTags file must be a structure" );  
-@@ -173,8 +173,8 @@ DEFUN_DLD( pfsput, args, , helpString)
-             throw pfs::Exception( "can not set channel tag if channel is missing" );
-           }
-           
--          octave_scalar_map tags = tagChannels.contents( itCh )(0).map_value();
--          for( octave_scalar_map::iterator itTag = tags.begin(); itTag != tags.end(); itTag++ ) {
-+          octave_map tags = tagChannels.contents( itCh )(0).map_value();
-+          for( octave_map::iterator itTag = tags.begin(); itTag != tags.end(); itTag++ ) {
-             std::string tagName = tags.key(itTag);
-             if( !tags.contents( itTag )(0).is_string() ) 
-               throw pfs::Exception( "all channel tags must be given as strings" );
diff --git a/pfstools-2.0.4-octinstall.patch b/pfstools-2.0.4-octinstall.patch
deleted file mode 100644 (file)
index bbb6c58..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-diff -up pfstools-2.0.4/CMakeLists.txt.octinstall pfstools-2.0.4/CMakeLists.txt
---- pfstools-2.0.4/CMakeLists.txt.octinstall   2015-07-20 13:06:32.533996797 +0200
-+++ pfstools-2.0.4/CMakeLists.txt      2015-07-20 13:11:35.728808062 +0200
-@@ -277,8 +277,6 @@ OPTION(WITH_HDRVC "Compile HDRVC (intern
- # ======== MKOCTFILE/OCTAVE ===========
- OPTION(WITH_Octave "Compile Octave files" ON)
--SET (OCTAVE_DEST_DIR "${CMAKE_INSTALL_PREFIX}/share/pfstools/octave"
--CACHE PATH  "Copy octave functions to this directory")
- if( WITH_Octave )
-   
-@@ -289,7 +287,8 @@ if( WITH_Octave )
-   if(MKOCTFILE)
-     message(STATUS "mkoctfile found.")
-   endif()
--
-+  execute_process(COMMAND octave-config --oct-site-dir OUTPUT_VARIABLE OCTAVE_OCT_DIR OUTPUT_STRIP_TRAILING_WHITESPACE)
-+  execute_process(COMMAND octave-config --m-site-dir OUTPUT_VARIABLE OCTAVE_M_DIR OUTPUT_STRIP_TRAILING_WHITESPACE)
- endif( WITH_Octave )
- # ======== OpenCV ===========
-diff -up pfstools-2.0.4/src/octave/CMakeLists.txt.octinstall pfstools-2.0.4/src/octave/CMakeLists.txt
---- pfstools-2.0.4/src/octave/CMakeLists.txt.octinstall        2015-07-20 13:03:30.448679088 +0200
-+++ pfstools-2.0.4/src/octave/CMakeLists.txt   2015-07-20 13:12:42.873544809 +0200
-@@ -40,11 +40,11 @@ endforeach(SRC)
- foreach(SRC ${SRC_OCT}) 
-       install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${SRC}.oct 
-                PERMISSIONS OWNER_EXECUTE GROUP_EXECUTE WORLD_EXECUTE OWNER_WRITE WORLD_READ GROUP_READ OWNER_READ
--               DESTINATION ${OCTAVE_DEST_DIR})
-+               DESTINATION "${OCTAVE_OCT_DIR}/pfstools")
- endforeach(SRC)
- foreach(SRC ${SRC_M}) 
--      install (FILES ${SRC} DESTINATION ${OCTAVE_DEST_DIR})
-+      install (FILES ${SRC} DESTINATION "${OCTAVE_M_DIR}/pfstools")
- endforeach(SRC)
- install (FILES ${OCT_SCRIPTS} 
index 73ea9ac57317da7d4c46391d84c59532253adc1e..606fdabb3d9bed51b6b9640fe1d8adc4802dc8c8 100644 (file)
@@ -6,15 +6,13 @@
 Summary:       pfstools for High Dynamic Range Images and Video
 Summary(pl.UTF-8):     Narzędzia do obrazów i wideo o dużym zakresie luminancji
 Name:          pfstools
-Version:       2.0.4
-Release:       10
+Version:       2.0.6
+Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/pfstools/%{name}-%{version}.tgz
-# Source0-md5: f17e2834798cda75d32b2fcd11826d82
-Patch0:                pfstools-2.0.4-maptype.patch
-Patch1:                pfstools-2.0.4-octinstall.patch
-Patch2:                imagemagick7.patch
+# Source0-md5: c3148ed11e562c30a0fd65d114cf2de2
+Patch0:                imagemagick7.patch
 URL:           http://pfstools.sourceforge.net/
 BuildRequires: ImageMagick-c++-devel >= 6.0
 BuildRequires: OpenEXR-devel >= 1.0
@@ -95,8 +93,6 @@ Wiązania języka Octave do pfstools.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
-%patch2 -p1
 
 %build
 install -d build
@@ -124,7 +120,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog README TODO doc/faq.txt doc/pfs_format_spec.pdf
+%doc AUTHORS ChangeLog README doc/faq.txt doc/pfs_format_spec.pdf
 %attr(755,root,root) %{_libdir}/libpfs.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libpfs.so.2
 
This page took 0.10878 seconds and 4 git commands to generate.