]> git.pld-linux.org Git - packages/perl-X11-GUITest.git/blob - perl-X11-GUITest.spec
- rebuild for perl 5.20
[packages/perl-X11-GUITest.git] / perl-X11-GUITest.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    X11
7 %define         pnam    GUITest
8 Summary:        X11::GUITest - GUI testing/interaction facilities
9 Summary(pl.UTF-8):      X11::GUITest - ułatwienia do testowania/interakcji z GUI
10 Name:           perl-X11-GUITest
11 Version:        0.25
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/X11/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  c2ea2418a5cef380e260dce9230c1d8b
18 URL:            http://search.cpan.org/dist/X11-GUITest/
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  xorg-lib-libX11-devel
21 BuildRequires:  xorg-lib-libXext-devel
22 BuildRequires:  xorg-lib-libXtst-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This Perl package is intended to facilitate the testing of GUI
27 applications by means of user emulation. It can be used to
28 test/interact with GUI applications which have been built upon the X
29 library or toolkits (i.e., GTK+, Xt, Qt, Motif, etc.) that "wrap" the
30 X library's functionality.
31
32 %description -l pl.UTF-8
33 Ten pakiet Perla ma ułatwić testowanie aplikacji z graficznym
34 interfejsem użytkownika drogą emulacji użytkownika. Może być używany
35 do testowania lub interakcji z aplikacjami GUI opartymi o bibliotekę X
36 lub toolkity (takie jak GTK+, Xt, Qt, Motif itp.) obudowujące
37 funkcjonalność biblioteki X.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc docs/{Changes,ToDo,X11-GUITest*}
61 %dir %{perl_vendorarch}/X11
62 %{perl_vendorarch}/X11/GUITest.pm
63 %dir %{perl_vendorarch}/auto/X11
64 %dir %{perl_vendorarch}/auto/X11/GUITest
65 %attr(755,root,root) %{perl_vendorarch}/auto/X11/GUITest/GUITest.so
66 %{perl_vendorarch}/auto/X11/GUITest/GUITest.bs
67 %{_mandir}/man3/*
This page took 0.026953 seconds and 3 git commands to generate.