]> git.pld-linux.org Git - packages/perl-Type-Tiny.git/blob - perl-Type-Tiny.spec
- up to 1.002001
[packages/perl-Type-Tiny.git] / perl-Type-Tiny.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Type
6 %define         pnam    Tiny
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Type::Tiny - tiny, yet Moo(se)-compatible type constraint
9 Name:           perl-Type-Tiny
10 Version:        1.002001
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/T/TO/TOBYINK/Type-Tiny-%{version}.tar.gz
16 # Source0-md5:  9a529fd6524d75e6cbfeb33df5237db9
17 URL:            http://search.cpan.org/dist/Type-Tiny/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Exporter-Tiny >= 0.026
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Type::Tiny is a tiny class for creating Moose-like type constraint
28 objects which are compatible with Moo, Moose and Mouse.
29
30 Maybe now we won't need to have separate MooseX, MouseX and MooX
31 versions of everything? We can but hope...
32
33 This documents the internals of Type::Tiny. Type::Tiny::Manual is a
34 better starting place if you're new.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} pure_install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes CREDITS INSTALL NEWS README TODO
61 %{perl_vendorlib}/Devel/TypeTiny
62 %{perl_vendorlib}/Error/TypeTiny.pm
63 %{perl_vendorlib}/Error/TypeTiny
64 %{perl_vendorlib}/Eval/TypeTiny.pm
65 %{perl_vendorlib}/Reply/Plugin/TypeTiny.pm
66 %{perl_vendorlib}/Test/TypeTiny.pm
67 %{perl_vendorlib}/Type
68 %{perl_vendorlib}/Types
69 %{_mandir}/man3/*
70 %{_examplesdir}/%{name}-%{version}
This page took 0.085328 seconds and 3 git commands to generate.