]> git.pld-linux.org Git - packages/perl-Text-DHCPLeases.git/blob - perl-Text-DHCPLeases.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Text-DHCPLeases.git] / perl-Text-DHCPLeases.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests   # do not perform "make test"
5 #
6 %define         pdir    Text
7 %define         pnam    DHCPLeases
8 Summary:        -
9 Summary(pl.UTF-8):      -
10 Name:           perl-Text-DHCPLeases
11 Version:        0.8
12 Release:        0.1
13 # note if it is "same as perl"
14 #License:       GPL v1+ or Artistic
15 License:        (enter GPL/LGPL/BSD/BSD-like/Artistic/other license name here)
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/Text/%{pdir}-%{pnam}-v%{version}.tar.gz
18 # Source0-md5:  
19 #Patch0:                %{name}-foo.patch
20 # most of CPAN modules have generic URL (substitute pdir and pnam here)
21 URL:            http://search.cpan.org/dist/Text-DHCPLeases/
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 #BuildRequires: -
25 %if %{with autodeps} || %{with tests}
26 #BuildRequires: perl-
27 #BuildRequires: perl-
28 %endif
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _noautoreq      'perl(anything_fake_or_conditional)'
33
34 %description
35 This module provides an object-oriented interface to ISC DHCPD leases files.
36 The goal is to objectify all declarations, as defined by the ISC dhcpd package
37 man pages.
38
39 This interface is useful for analyzing, reporting, converting lease files, or
40 as a tool for other applications that need to import dhcpd lease data
41 structures.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-v%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} pure_install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README
66 %{perl_vendorlib}/Text/DHCPLeases.pm
67 %dir %{perl_vendorlib}/Text/DHCPLeases
68 %{perl_vendorlib}/Text/DHCPLeases/*.pm
69 %dir %{perl_vendorlib}/Text/DHCPLeases/Object
70 %{perl_vendorlib}/Text/DHCPLeases/Object/*.pm
71 %{_mandir}/man3/*
This page took 0.116205 seconds and 3 git commands to generate.