]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blob - perl-Test-Simple.spec
- version 0.50, informative summary, better description
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Simple
8 Summary:        Test::Simple - basic utilities for writing tests
9 Summary(pl):    Test::Simple - podstawowe narzêdzia do pisania testów
10 Name:           perl-Test-Simple
11 Version:        0.50
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  df12f1f522307850577992d2da5ba04f
18 # Source0-size: 51334
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 # false requires found by rpm 4.0.2
25 %if "%(perl -MConfig -e 'print $Config{useithreads};')" != "define"
26 %define         _noautoreq      'perl(threads)' 'perl(threads::shared)'
27 %else
28 Requires:       perl(threads) perl(threads::shared)
29 %endif
30
31 %description
32 AHHHHHHH!!!!  NOT TESTING!  Anything but testing!  Beat me, whip me,
33 send me to Detroit, but don't make me write tests!
34         -- perldoc Test::Tutorial
35
36 Test::Simple is an extremely simple, extremely basic module for writing
37 tests suitable for CPAN modules and other pursuits. If you wish to do
38 more complicated testing, use the Test::More module (a drop-in replacement
39 for this one).
40
41 The purpose of Test::More is to provide a wide range of testing utilities.
42 Various ways to say "ok" with better diagnostics, facilities to skip
43 tests, test future features and compare complicated data structures.
44 While you can do almost anything with a simple "ok()" function, it
45 doesn't provide good diagnostic output.
46
47 #%description -l pl
48 #Test::Simple jest bardzo prostym, bardzo podstawowym modu³em do pisania
49 #testów pasuj±cych do modu³ów CPAN i innych. Do bardziej skomplikowanych
50 #testów lepiej u¿ywaæ modu³u Test::More (zastêpuj±cego ten).
51 # to be updated
52
53 %prep
54 %setup -q -n %{pdir}-%{pnam}-%{version}
55 rm -f t/00signature.t
56
57 %build
58 %{__perl} Makefile.PL \
59         INSTALLDIRS=vendor
60 %{__make}
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes README TODO
76 %{perl_vendorlib}/Test/*.pm
77 %{_mandir}/man3/*
This page took 0.067458 seconds and 4 git commands to generate.