]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blob - perl-Test-Simple.spec
c9d154ddd41a194545e64b3c95930bdcc4b98515
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Simple
8 Summary:        Test::Simple - basic utilities for writing tests
9 Summary(pl.UTF-8):      Test::Simple - podstawowe narzędzia do pisania testów
10 Name:           perl-Test-Simple
11 Version:        1.302062
12 %define fver    %(echo %{version} | tr -d _)
13 Release:        2
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{fver}.tar.gz
18 # Source0-md5:  d869f6754eccc38484da7e21e9c7bbcc
19 URL:            http://search.cpan.org/dist/Test-Simple/
20 %{?with_tests:BuildRequires:    perl-Test-Harness >= 2.03}
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 # see lib/Test/Builder/Tester.pm /VERSION
24 Provides:       perl-Test-Builder-Tester = %{version}
25 # see lib/Test/Tester.pm /VERSION
26 Provides:       perl-Test-Tester = %{version}
27 Obsoletes:      perl-Test-Builder-Tester < %{version}
28 Obsoletes:      perl-Test-Tester < %{version}
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _noautoreq      'perl(threads)' 'perl(threads::shared)'
33
34 %description
35 AHHHHHHH!!!! NOT TESTING! Anything but testing! Beat me, whip me, send
36 me to Detroit, but don't make me write tests!
37    -- perldoc Test::Tutorial
38
39 Test::Simple is an extremely simple, extremely basic module for
40 writing tests suitable for CPAN modules and other pursuits. If you
41 wish to do more complicated testing, use the Test::More module (a
42 drop-in replacement for this one).
43
44 The purpose of Test::More is to provide a wide range of testing
45 utilities. Various ways to say "ok" with better diagnostics,
46 facilities to skip tests, test future features and compare complicated
47 data structures. While you can do almost anything with a simple "ok()"
48 function, it doesn't provide good diagnostic output.
49
50 %description -l pl.UTF-8
51 AAAAAAAA!!! NIE TESTOWANIE! Wszystko tylko nie testowanie! Bijcie
52 mnie, biczujcie mnie, wyślijcie do Detroit, ale nie każcie pisać
53 testów!
54    -- perldoc Test::Tutorial
55
56 Test::Simple jest bardzo prostym, bardzo podstawowym modułem do
57 pisania testów pasujących do modułów CPAN i innych. Do bardziej
58 skomplikowanych testów lepiej używać modułu Test::More (zastępującego
59 ten).
60
61 Celem Test::More jest dostarczenie szerokiego zakresu narzędzi do
62 testowania. Różne sposoby powiedzenia "ok" z lepszą diagnostyką,
63 ułatwienia przy pomijaniu testów, testowaniu przyszłych możliwości i
64 porównywaniu skomplikowanych struktur danych. O ile można zrobić
65 prawie wszystko prostą funkcją "ok()", nie daje ona dobrego wyjścia
66 diagnostycznego.
67
68 %prep
69 %setup -q -n %{pdir}-%{pnam}-%{fver}
70 %{__perl} -nli -e 'print unless /^\s+sleep\s+\d+;\s*/' Makefile.PL
71
72 %build
73 %{__perl} Makefile.PL \
74         INSTALLDIRS=vendor
75 %{__make}
76
77 %{?with_tests:%{__make} test}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Test/Tutorial.pod
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc Changes README
93 %{perl_vendorlib}/ok.pm
94 %{perl_vendorlib}/Test/Builder
95 %{perl_vendorlib}/Test/Builder.pm
96 %{perl_vendorlib}/Test/More.pm
97 %{perl_vendorlib}/Test/Simple.pm
98 %{perl_vendorlib}/Test/Tester
99 %{perl_vendorlib}/Test/Tester.pm
100 %{perl_vendorlib}/Test/use
101 %{perl_vendorlib}/Test2.pm
102 %{perl_vendorlib}/Test2
103 %{_mandir}/man3/Test::Builder*.3pm*
104 %{_mandir}/man3/Test::More.3pm*
105 %{_mandir}/man3/Test::Simple.3pm*
106 %{_mandir}/man3/Test::Tester*.3pm*
107 %{_mandir}/man3/Test::Tutorial.3pm*
108 %{_mandir}/man3/Test::use::ok.3pm*
109 %{_mandir}/man3/Test2*.3pm*
110 %{_mandir}/man3/ok.3pm*
This page took 0.026672 seconds and 2 git commands to generate.