]> git.pld-linux.org Git - packages/perl-Plack.git/blob - perl-Plack.spec
- ver. 0.9986
[packages/perl-Plack.git] / perl-Plack.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Plack
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Plack - Perl Superglue for Web frameworks and Web Servers (PSGI toolkit)
8 #Summary(pl.UTF-8):
9 Name:           perl-Plack
10 Version:        0.9986
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Plack/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  90d63ab0dc479136906db43ab9a99df1
17 Patch0:         %{name}-tests.patch
18 URL:            http://search.cpan.org/dist/Plack/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(Devel::StackTrace::AsHTML) >= 0.11
23 BuildRequires:  perl(Filesys::Notify::Simple)
24 BuildRequires:  perl(HTTP::Body) >= 1.06
25 BuildRequires:  perl(Hash::MultiValue) >= 0.05
26 BuildRequires:  perl(Test::Requires)
27 BuildRequires:  perl(Test::TCP) >= 0.11
28 BuildRequires:  perl-Devel-StackTrace >= 1.23
29 BuildRequires:  perl-File-ShareDir >= 1.00
30 BuildRequires:  perl-HTTP-Request-AsCGI
31 BuildRequires:  perl-Try-Tiny
32 BuildRequires:  perl-URI >= 1.36
33 BuildRequires:  perl-libwww >= 5.814
34 %endif
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _noautoreq      'perl(Apache::Constants)' 'perl(Apache::Request)'
39
40 %description
41 Plack is a set of tools for using the PSGI stack. It contains
42 middleware components, a reference server and utilities for Web
43 application frameworks. Plack is like Ruby's Rack or Python's Paste
44 for WSGI.
45
46 See PSGI for the PSGI specification and PSGI::FAQ to know what PSGI
47 and Plack are and why we need them.
48
49
50
51 # %description -l pl.UTF-8 # TODO
52
53 %prep
54 %setup -q -n %{pdir}-%{version}
55 %patch0 -p1
56
57 %build
58 %{__perl} Makefile.PL \
59         INSTALLDIRS=vendor
60 %{__make}
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} pure_install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
71 cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc Changes README
79 %{perl_vendorlib}/*.pm
80 %{perl_vendorlib}/Plack/
81 %{_mandir}/man1/*
82 %{_mandir}/man3/*
83 %{_examplesdir}/%{name}-%{version}
84 %attr(755,root,root) %{_bindir}/plackup
85 %{perl_vendorlib}/HTTP/Message/PSGI.pm
86 %{perl_vendorlib}/HTTP/Server/PSGI.pm
87 %{perl_vendorlib}/auto/share/dist/Plack
This page took 0.079442 seconds and 4 git commands to generate.