]> git.pld-linux.org Git - packages/perl-Plack.git/blob - perl-Plack.spec
- up to 1.0034
[packages/perl-Plack.git] / perl-Plack.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Plack
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Plack - Perl Superglue for Web frameworks and Web Servers (PSGI toolkit)
8 #Summary(pl.UTF-8):
9 Name:           perl-Plack
10 Version:        1.0034
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Plack/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  519364cae9df1f2845fd803d75dc8b3c
17 URL:            http://search.cpan.org/dist/Plack/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Devel::StackTrace::AsHTML) >= 0.11
22 BuildRequires:  perl(Filesys::Notify::Simple)
23 BuildRequires:  perl(HTTP::Body) >= 1.06
24 BuildRequires:  perl(Hash::MultiValue) >= 0.05
25 BuildRequires:  perl(Test::Requires)
26 BuildRequires:  perl(Test::TCP) >= 0.11
27 BuildRequires:  perl-Apache-LogFormat-Compiler
28 BuildRequires:  perl-Devel-StackTrace >= 1.23
29 BuildRequires:  perl-File-ShareDir >= 1.00
30 BuildRequires:  perl-File-ShareDir-Install
31 BuildRequires:  perl-HTTP-Request-AsCGI
32 BuildRequires:  perl-Stream-Buffered
33 BuildRequires:  perl-Try-Tiny
34 BuildRequires:  perl-URI >= 1.36
35 BuildRequires:  perl-libwww >= 5.814
36 %endif
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _noautoreq_perl 'Apache::Constants' 'Apache::Request'
41
42 %description
43 Plack is a set of tools for using the PSGI stack. It contains
44 middleware components, a reference server and utilities for Web
45 application frameworks. Plack is like Ruby's Rack or Python's Paste
46 for WSGI.
47
48 See PSGI for the PSGI specification and PSGI::FAQ to know what PSGI
49 and Plack are and why we need them.
50
51
52
53 # %description -l pl.UTF-8 # TODO
54
55 %prep
56 %setup -q -n %{pdir}-%{version}
57
58 %build
59 %{__perl} Makefile.PL \
60         INSTALLDIRS=vendor
61 %{__make}
62
63 %{?with_tests:%{__make} test}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} pure_install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
72 cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc Changes README
80 %{perl_vendorlib}/*.pm
81 %{perl_vendorlib}/Plack/
82 %{_mandir}/man1/*
83 %{_mandir}/man3/*
84 %{_examplesdir}/%{name}-%{version}
85 %attr(755,root,root) %{_bindir}/plackup
86 %{perl_vendorlib}/HTTP/Message/PSGI.pm
87 %{perl_vendorlib}/HTTP/Server/PSGI.pm
88 %{perl_vendorlib}/auto/share/dist/Plack
This page took 0.067293 seconds and 3 git commands to generate.