]> git.pld-linux.org Git - packages/perl-Plack.git/blob - perl-Plack.spec
- rpm5 noautoreq
[packages/perl-Plack.git] / perl-Plack.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Plack
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Plack - Perl Superglue for Web frameworks and Web Servers (PSGI toolkit)
8 #Summary(pl.UTF-8):
9 Name:           perl-Plack
10 Version:        0.9986
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Plack/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  90d63ab0dc479136906db43ab9a99df1
17 URL:            http://search.cpan.org/dist/Plack/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Devel::StackTrace::AsHTML) >= 0.11
22 BuildRequires:  perl(Filesys::Notify::Simple)
23 BuildRequires:  perl(HTTP::Body) >= 1.06
24 BuildRequires:  perl(Hash::MultiValue) >= 0.05
25 BuildRequires:  perl(Test::Requires)
26 BuildRequires:  perl(Test::TCP) >= 0.11
27 BuildRequires:  perl-Devel-StackTrace >= 1.23
28 BuildRequires:  perl-File-ShareDir >= 1.00
29 BuildRequires:  perl-HTTP-Request-AsCGI
30 BuildRequires:  perl-Try-Tiny
31 BuildRequires:  perl-URI >= 1.36
32 BuildRequires:  perl-libwww >= 5.814
33 %endif
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _noautoreq_perl 'Apache::Constants' 'Apache::Request'
38
39 %description
40 Plack is a set of tools for using the PSGI stack. It contains
41 middleware components, a reference server and utilities for Web
42 application frameworks. Plack is like Ruby's Rack or Python's Paste
43 for WSGI.
44
45 See PSGI for the PSGI specification and PSGI::FAQ to know what PSGI
46 and Plack are and why we need them.
47
48
49
50 # %description -l pl.UTF-8 # TODO
51
52 %prep
53 %setup -q -n %{pdir}-%{version}
54
55 %build
56 %{__perl} Makefile.PL \
57         INSTALLDIRS=vendor
58 %{__make}
59
60 %{?with_tests:%{__make} test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} pure_install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
69 cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc Changes README
77 %{perl_vendorlib}/*.pm
78 %{perl_vendorlib}/Plack/
79 %{_mandir}/man1/*
80 %{_mandir}/man3/*
81 %{_examplesdir}/%{name}-%{version}
82 %attr(755,root,root) %{_bindir}/plackup
83 %{perl_vendorlib}/HTTP/Message/PSGI.pm
84 %{perl_vendorlib}/HTTP/Server/PSGI.pm
85 %{perl_vendorlib}/auto/share/dist/Plack
This page took 0.091027 seconds and 3 git commands to generate.