]> git.pld-linux.org Git - packages/perl-Plack.git/blob - perl-Plack.spec
- up to 1.0029
[packages/perl-Plack.git] / perl-Plack.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Plack
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Plack - Perl Superglue for Web frameworks and Web Servers (PSGI toolkit)
8 #Summary(pl.UTF-8):
9 Name:           perl-Plack
10 Version:        1.0029
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Plack/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  cb1cde10822715423948b7411456f2c4
17 URL:            http://search.cpan.org/dist/Plack/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Devel::StackTrace::AsHTML) >= 0.11
22 BuildRequires:  perl(Filesys::Notify::Simple)
23 BuildRequires:  perl(HTTP::Body) >= 1.06
24 BuildRequires:  perl(Hash::MultiValue) >= 0.05
25 BuildRequires:  perl(Test::Requires)
26 BuildRequires:  perl(Test::TCP) >= 0.11
27 BuildRequires:  perl-Devel-StackTrace >= 1.23
28 BuildRequires:  perl-File-ShareDir >= 1.00
29 BuildRequires:  perl-File-ShareDir-Install
30 BuildRequires:  perl-HTTP-Request-AsCGI
31 BuildRequires:  perl-Try-Tiny
32 BuildRequires:  perl-URI >= 1.36
33 BuildRequires:  perl-libwww >= 5.814
34 %endif
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _noautoreq_perl 'Apache::Constants' 'Apache::Request'
39
40 %description
41 Plack is a set of tools for using the PSGI stack. It contains
42 middleware components, a reference server and utilities for Web
43 application frameworks. Plack is like Ruby's Rack or Python's Paste
44 for WSGI.
45
46 See PSGI for the PSGI specification and PSGI::FAQ to know what PSGI
47 and Plack are and why we need them.
48
49
50
51 # %description -l pl.UTF-8 # TODO
52
53 %prep
54 %setup -q -n %{pdir}-%{version}
55
56 %build
57 %{__perl} Makefile.PL \
58         INSTALLDIRS=vendor
59 %{__make}
60
61 %{?with_tests:%{__make} test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} pure_install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
70 cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc Changes README
78 %{perl_vendorlib}/*.pm
79 %{perl_vendorlib}/Plack/
80 %{_mandir}/man1/*
81 %{_mandir}/man3/*
82 %{_examplesdir}/%{name}-%{version}
83 %attr(755,root,root) %{_bindir}/plackup
84 %{perl_vendorlib}/HTTP/Message/PSGI.pm
85 %{perl_vendorlib}/HTTP/Server/PSGI.pm
86 %{perl_vendorlib}/auto/share/dist/Plack
This page took 0.133824 seconds and 3 git commands to generate.